Support » Plugin: Jetpack by WordPress.com » Author image signature displayed twice after a post

  • Resolved zilchbjork

    (@zilchbjork)


    The gravatar picture is shwon twice after the post.
    Please check the link.
    I would need to show it of course once

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Jetpack overall doesn’t control the display of Gravatars, that’s controlled by your theme.

    Does it look correct under the Twenty Nineteen theme?

    Hi James!

    Thanks for your reply

    One image is displayed by JetPack, the other one by the theme. If I switch the theme with another one both images are still shown.

    Is there any method to disable the image shown by JetPack?

    avatar avatar-80 photo jetpack-lazy-image jetpack-lazy-image–handled

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    That doesn’t make much sense. You are seeing that because Jetpack’s Lazy Load module is controlling _how_ images are loaded, but not where.

    Does the double image go away when the Jetpack plugin is deactivated?

    The avatar duplication when Jetpack’s lazy load is activated also happens in my site.

    I tried linking to it so that you could see, but my comment was very silently flagged as spam and promptly deleted. 😛

    The authors of the theme say it’s because Jetpack creates another avatar and there’s no option to remove it.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    What you’re describing sounds a bit different.

    Would you please open your own thread at https://wordpress.org/support/plugin/jetpack/ or contact us at https://jetpack.com/contact-support/?rel=support ?

    Ok, done.

    I had the same problem with my theme. Jetpack’s lazy loading does actually print an extra avatar, but it’s placed between <noscript> tags. If your theme than uses wp_kses_post to escape scripts, it apparently also removes the <noscript> tags, hence making a second author image visible immediately after the original one.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.