WordPress.org

Forums

Postie
[resolved] Authentication problem with pop3-ssl (6 posts)

  1. StefanRauchDE
    Member
    Posted 1 year ago #

    Hi,
    my provider switched all mailboxes to SSL and so I have to update my Postie settings to SSL, too.
    Now the authentication does not work anymore.
    Here my settings:

    Mail Protocol: POP3-SSL
    TLS: NO
    Port: 995

    I tripplechecked the POP server URL, username and password :-)

    I sent some mails to process to my mailbox and ran Postie in debug mode, but no message is fetched.
    Here is the output:

    Starting mail fetch
    Postie Version: 1.5.18
    WordPres Version: 3.8.1
    PHP Version: 5.3.28
    OS: SunOS localhost 5.10 Generic_139556-08 i86pc
    Debug mode: On
    Time: 2014-01-31 05:38:34 GMT
    Error log:
    Postie is in /mnt/web1/e3/94/5299294/htdocs/site2/wp-content/plugins/postie
    Cron: On
    Alternate Cron: Off
    iconv: installed
    imap: installed
    mbstring: installed
    wp_content_path: /mnt/web1/e3/94/5299294/htdocs/site2/wp-content
    Connecting to pop3.strato.de:995 (pop3-ssl)
    IMAP: connection string - {pop3.strato.de:995/service=pop3/ssl/notls/novalidate-cert}
    IMAP: disabling GSSAPI
    Mail Connection Time Out
    Common Reasons: Server Down, Network Issue, Port/Protocol MisMatch
    Array
    (
        [0] => Can't open mailbox {pop3.strato.de:995/service=pop3/ssl/notls/novalidate-cert}: invalid remote specification
    )
    
    The Server said:
    IMAP: expunge
    IMAP: closing connection
    There are 0 messages to process

    http://wordpress.org/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Looking at their FAQ http://www.strato-faq.de/artikel.html?id=171 it appears you may need to turn TLS on.

  3. StefanRauchDE
    Member
    Posted 1 year ago #

    Hi Allen,
    this makes no difference - I turned TLS on and ran Postie in debug mode again with this result:

    Checking for mail manually with debug output
    Starting mail fetch
    Postie Version: 1.5.18
    WordPres Version: 3.8.1
    PHP Version: 5.3.28
    OS: SunOS localhost 5.10 Generic_139556-08 i86pc
    Debug mode: On
    Time: 2014-01-31 18:55:39 GMT
    Error log:
    Postie is in /mnt/web1/e3/94/5299294/htdocs/site2/wp-content/plugins/postie
    Cron: On
    Alternate Cron: Off
    iconv: installed
    imap: installed
    mbstring: installed
    wp_content_path: /mnt/web1/e3/94/5299294/htdocs/site2/wp-content
    IMAP: TLS enabled
    Connecting to pop3.strato.de:995 (pop3-ssl) with TLS
    IMAP: connection string - {pop3.strato.de:995/service=pop3/ssl/tls/novalidate-cert}
    IMAP: disabling GSSAPI
    Mail Connection Time Out
    Common Reasons: Server Down, Network Issue, Port/Protocol MisMatch
    Array
    (
        [0] => Can't open mailbox {pop3.strato.de:995/service=pop3/ssl/tls/novalidate-cert}: invalid remote specification
    )
    
    The Server said:
    IMAP: expunge
    IMAP: closing connection
  4. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    You may need to verify that your hosting company allows outbound connections on port 995 from your website.

  5. tyme2tb
    Member
    Posted 1 year ago #

    I have the same issue. Below is my results of debug with and without TLS. If it is the hosting company how do I check for if they allow the outbound ports?

    I can connect to the pop server from another application. I did check that.

    #### Without TLS ####

    Checking for mail manually with debug output

    Starting mail fetch

    Postie Version: 1.5.18

    WordPres Version: 3.8

    PHP Version: 5.4.24

    OS: Linux host202.hostmonster.com 2.6.32-20130307.60.9.bh6.x86_64 #1 SMP Thu Mar 7 15:58:33 EST 2013 x86_64

    Debug mode: On

    Time: 2014-02-05 18:48:11 GMT

    Error log: error_log

    Postie is in ____________________________

    Cron: On

    Alternate Cron: Off

    iconv: installed

    imap: installed

    mbstring: installed

    wp_content_path: ____________________________

    Connecting to pop-mail.outlook.com:995 (pop3-ssl)

    IMAP: connection string - {pop-mail.outlook.com:995/service=pop3/ssl/notls/novalidate-cert}

    IMAP: disabling GSSAPI

    Mail Connection Time Out

    Common Reasons: Server Down, Network Issue, Port/Protocol MisMatch

    Array
    (
    [0] => Can't connect to pop3.glbdns2.microsoft.com,995: Connection timed out
    )

    The Server said:

    IMAP: closing connection

    #### With TLS ####

    Checking for mail manually with debug output

    Starting mail fetch

    Postie Version: 1.5.18

    WordPres Version: 3.8

    PHP Version: 5.4.24

    OS: Linux host202.hostmonster.com 2.6.32-20130307.60.9.bh6.x86_64 #1 SMP Thu Mar 7 15:58:33 EST 2013 x86_64

    Debug mode: On

    Time: 2014-02-05 18:51:16 GMT

    Error log: error_log

    Postie is in ____________________________

    Cron: On

    Alternate Cron: Off

    iconv: installed

    imap: installed

    mbstring: installed

    wp_content_path: __________________________________

    IMAP: TLS enabled

    Connecting to pop-mail.outlook.com:995 (pop3-ssl) with TLS

    IMAP: connection string - {pop-mail.outlook.com:995/service=pop3/ssl/tls/novalidate-cert}

    IMAP: disabling GSSAPI

    Mail Connection Time Out

    Common Reasons: Server Down, Network Issue, Port/Protocol MisMatch

    Array
    (
    [0] => Can't open mailbox {pop-mail.outlook.com:995/service=pop3/ssl/tls/novalidate-cert}: invalid remote specification
    )

    The Server said:

    IMAP: closing connection

  6. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    >how do I check for if they allow the outbound ports?

    You will have to ask them. GoDaddy hosting in particular won't allow this. See http://postieplugin.com/postie-godaddy/

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Postie
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic