Support » Plugin: Next Active Directory Integration » Authentication failed

  • 2016-09-20 21:15:34 [DEBUG] NextADInt_Adi_Authentication_LoginService::getWordPressUser [line 610] User ’emuller’ has ID ‘3’.
    2016-09-20 21:15:34 [DEBUG] NextADInt_Adi_Authentication_LoginService::tryAuthenticatableSuffixes [line 167] Credentials={login=’emuller’,sAMAccountName=’emuller’,userPrincipalName=’emuller@’}’ with authenticatable suffixes: ”.
    2016-09-20 21:15:34 [WARN ] NextADInt_Adi_Authentication_LoginService::tryAuthenticatableSuffixes [line 192] Login for Credentials={login=’emuller’,sAMAccountName=’emuller’,userPrincipalName=’emuller@’} failed: none of the suffixes succeeded
    2016-09-20 21:15:34 [DEBUG] NextADInt_Adi_Authentication_PasswordValidationService::overridePasswordCheck [line 108] User from AD and fallback to local (WordPress) password deactivated. Authentication failed.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author FatSquirrel

    (@fatsquirrel)

    Hello emuller

    I´ve looked into your problem and was able to reproduce it.
    When logging in you probably just entered the username emuller and entered the password.

    The log tells us none of the suffixes succeeded.
    When logging in you need to add your domain suffix e.g. emuller@domain.tld

    This should solve your problem.

    Alternatively you could define a suffix by adding it to Active Directory Integration –> Configuration –> User –> Account suffix. After adding your suffix you should then be able to log in with only your username (emuller)

    I hope I could solve your problem. If you still encounter this problem, please let us know.

    If I have set the suffix, but still it does not work. Before the other plugins using Active Directory “Active Directory Integration” and it worked. But we are migrating to this plugins to make logins with different AD. Here goes a screenshot.

    https://dl.dropboxusercontent.com/u/74486468/ticketTheme/AD_suffix.JPG

    Plugin Author FatSquirrel

    (@fatsquirrel)

    Hey emuller

    I´ve looked at your screenshot. It seems like you didnt actualy add the suffix by pressing the plus icon next to the input field. Please make sure it is added as shown in my screenshot.

    nADI suffix setting

    Let me know, if this is the problem.

    • This reply was modified 2 years, 10 months ago by  FatSquirrel.

    We have made the change but continue with the same mistakes, attached log:

    AD

    [INFO ] NextADInt_Adi_Authentication_LoginService::authenticate [line 130] A user tries to log in.
    [DEBUG] NextADInt_Adi_Authentication_LoginService::getWordPressUser [line 610] User 'emuller' has ID '3'.
    [DEBUG] NextADInt_Adi_Authentication_LoginService::tryAuthenticatableSuffixes [line 167] Credentials={login='emuller',sAMAccountName='emuller',userPrincipalName='emuller@'}' with authenticatable suffixes: ''.
    [WARN ] NextADInt_Adi_Authentication_LoginService::tryAuthenticatableSuffixes [line 192] Login for Credentials={login='emuller',sAMAccountName='emuller',userPrincipalName='emuller@'} failed: none of the suffixes succeeded
    [DEBUG] NextADInt_Adi_Authentication_PasswordValidationService::overridePasswordCheck [line 108] User from AD and fallback to local (WordPress) password deactivated. Authentication failed.

    The connection test works:

    2016-09-21 14:24:34 [INFO ] NextADInt_Ldap_Connection::createConfiguration [line 101] LDAP connection is *not* encrypted
    2016-09-21 14:24:34 [DEBUG] NextADInt_Ldap_Connection::createConfiguration [line 102] Array
    (
        [account_suffix] =>
        [base_dn] => DC=autopistacentral,DC=cl
        [domain_controllers] => Array
            (
                [0] => 10.33.203.10
                [1] => 10.33.203.1
            )
    
        [ad_port] => 389
        [use_tls] =>
        [network_timeout] => 5
        [ad_username] => emuller@autopistacentral.cl
        [ad_password] => *** protected password ***
    )
    
    2016-09-21 14:24:34 [DEBUG] NextADInt_Ldap_Connection::findAttributesOfUser [line 358] Import these attributes from ad for the user 'emuller@autopistacentral.cl': Array
    (
        [0] => objectsid
    )
    
    2016-09-21 14:24:34 [DEBUG] NextADInt_Ldap_Connection::findAttributesOfUser [line 370] UserInfo for user 'emuller@autopistacentral.cl': Array
    (
        [objectsid] => Array
            (
                [count] => 1
                [0] => ▒=+F%▒GC
    2▒$
            )
    
        [0] => objectsid
        [count] => 1
        [dn] => CN=Enrique Muller,OU=xxxxxx,OU=Autopista Central,OU=Mi Organizacion,DC=autopistacentral,DC=cl
    )
    • This reply was modified 2 years, 10 months ago by  emuller.
    Plugin Author tobi823

    (@tobi823)

    Hi emuller,

    is it possible, that this issue is caused by an other plugin? Next ADI does not work with https://de.wordpress.org/plugins/wps-hide-login/ because this plugin change the url to the login page.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Authentication failed’ is closed to new replies.