Support » Plugin: Constant Contact for WordPress » Authentication doesnt works

  • I have upgraded plugin to 4.0.2, and the shortcode constantcontactapi now not working, when i deactivated it and again activate, it asks for constact contact api, after successful authentication, it again comes to the page in backend where it says you need to authenticate to use plugin features? I have also tried version 4.0.1 to check if it resolves but nothing works, plz help

    https://wordpress.org/plugins/constant-contact-api/

Viewing 4 replies - 1 through 4 (of 4 total)
  • anyone?

    Plugin Author Zack Katz

    (@katzwebdesign)

    Hi Swayam – I’m afraid I can’t debug individual sites. If you’re able to provide your server details or any additional logs, that would be helpful: zack@katz.co

    Hi zack – I have defined my own “CTCT_APIKEY” & “CTCT_APISECRET” in wp-config.php, but it gives me error of “Invalid redirect”, after some debugging i found that the plugin is using their own redirect url instead of what we set while creating app, so i have tried to set domain name in settings of CC and in plugin also in “class.kwsoauth2.php” but still no luck, its showing me like this http://awesomescreenshot.com/01b60je155

    Plugin Author Zack Katz

    (@katzwebdesign)

    Hi Swayam – I recommend making sure your request is structured the same as the default. Also, maybe there’s something as basic as a difference in the trailing slash in the Redirect URI vs. what you’re passing to CTCT?

    You could also try getting in touch with the Constant Contact developer support team and see if they have any insights.

    Note: you can (and should, so it doesn’t get overwritten) use the ctct_oauth_uri_base filter to modify the OAuth URL.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Authentication doesnt works’ is closed to new replies.