Support » Plugin: Autoptimize » Auptoptimize 2.4 “war room”

  • ResolvedPlugin Author Optimizing Matters

    (@optimizingmatters)


    As you might have noticed I have just released Autoptimize 2.4. This thread is where you can report suspected issues with the update until let’s say the end of Sept.

Viewing 15 replies - 16 through 30 (of 40 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    The post has not been approved yet @vineettalwar, but based on the error (which I did see in the notificaction mail I received) this is due to a problem with a JS-file which the JS optimizer chokes on.

    so some questions;
    * you have “optimize JS” on I suppose?
    * what (if anything) are you excluding from optimization?
    * could you try the following code snippet to see if that changes things;

    
    add_filter('autoptimize_filter_js_minify_excluded','__return_false');

    frank

    Vineet

    (@vineettalwar)

    Hi, somehow I cant see that post also yet.
    Not sure if you can see the other options from previous mail, I have added w3 total cache settings as well.
    – Based on error log( deduced from the website), its choking on js of plugin ‘super socializer’

    1. Yes JS optimize is On.
    2. excluding JS
    seal.js, js/jquery/jquery.js,
    3. Tried, this doesn’t help either. Same fatal error.

    4. However, site goes normal if I have downgraded the plugin to 2.3.4

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    very interesting @vineettalwar … so in W3TC all minification is off, right? can you share your site’s URL?

    @optimizingmatters

    Thanks the github update for autoptimizeBase.php fixed the issue on both the live site with the custom theme and test site with twentyseventeen.

    Site crashes when the plugin is activated. Only on the front end though. I had to do a restore today. Thought it was another plugin but I did a plugin by plugin check. This one breaks the site. Deactivated until an update is pushed.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    thanks for the confirmation @antonynz, this will be part of the next minor update but given this is an edge case (as it requires the do_minify filters to be falsed) I won’t push it out immediately.

    @jamonkey; for an update to be pushed that fixes your problem I’ll need to understand your problem better, so here are some questions;
    * what does “crashed” mean? a white screen of death? text but no style? javascript broken?
    * is there any relevant info in your php-errorlog?
    * have you (or can you) try to toggle individual optimitions (HTML, CSS and JS, the stuff in “extra”) off (and back on) to identify which one “crashes” the site?

    1

    Autoptimize does not seem to work after updating to version 2.4.0.

    Cache info says 0 files cached, size 0.00 B, no matter how many pages I visit. I have checked the settings, cleared all caches and even restarted my VPS.

    AH01071: Got error 'PHP message: PHP Fatal error: Uncaught JSMin_UnterminatedStringException: JSMin: Unterminated String at byte 456: 'http://support.heateor.com/browser-blocking-social-features/\\' target=\\'_blank\\' style=\\'color:#33a9d8\\'>http://support.heateor.com/browser-blocking-social-features/</a> to unblock these.; in /fadingmusic.com/httpdocs/wp-content/plugins/autoptimize/classes/external/php/jsmin.php:211\nStack trace:\n#0 /fadingmusic.com/httpdocs/wp-content/plugins/autoptimize/classes/external/php/jsmin.php(152): JSMin->action(1)\n#1 /fadingmusic.com/httpdocs/wp-content/plugins/autoptimize/classes/external/php/jsmin.php(86): JSMin->min()\n#2 /fadingmusic.com/httpdocs/wp-content/plugins/autoptimize/classes/autoptimizeSpeedupper.php(38): JSMin::minify(‘var theChampDef…’)\n#3 /fadingmusic.com/httpdocs/wp-includes/class-wp-hook.php(286): autoptimizeSpeedupper->js_snippetcacher(‘var theChampDef…’, ”)\n#4 /fadingmusic.com/httpdoc…\n’,`

    • This reply was modified 3 years, 2 months ago by FadingMusic.
    • This reply was modified 3 years, 2 months ago by FadingMusic.
    • This reply was modified 3 years, 2 months ago by FadingMusic.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    @fadingmusic; there seems to be an issue with the “super socializer” plugin, are you indeed using that as well? can you try excluding that from JS optimization?

    Thank you, it showed in my logs after updating your plugin. For testing purposes, I disabled autoptimize and my site is working fast again.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    @fadingmusic ok but are you indeeed using “super socializer” plugin and if so can you try excluding that from JS optimization?

    Yes, but adding all JS files related to that plugin did not work strangely enough, but I have managed to solve the problem by deselecting “Also aggregated inline JS?” not that it was such a great idea to start with.

    Thank you for your quick response and excellent support.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    so for super socializer; there is a small bug in the inline code which indeed breaks AO if “aggrate inline JS” is on (which is off by default), I’ve logged a ticket on their support forum.

    Hi.
    It seems that’s there a big incompatibility problem with the plugin “Google Analytics Dashboard for WP (GADWP)” because my stats collapsed from around 800-1200 users by day to 200 :(.
    As soon as I’ve restored the previous release all was coming back to normal.

    Hoping you’ll find a solution.

    All the best,

    Pierre.

    Vineet

    (@vineettalwar)

    Hi,
    Yes, the minification is off in W3TC completely. I have added, the options that I am using in W3TC here
    Right now, I have reverted the version to 2.3.4, since, it was causing the production site to fail.

    If you want, I can simulate the issue on a testing stage with similar issue and send you access per mail.
    Do let me know 🙂

    Regards,
    Vineet

Viewing 15 replies - 16 through 30 (of 40 total)
  • The topic ‘Auptoptimize 2.4 “war room”’ is closed to new replies.