Support » Fixing WordPress » AUdioblog video post with 2.0

  • Has anyone successfully used Audioblog to post video with WP 2.0?
    It takes the text fine but doesn’t show the video.

Viewing 15 replies - 1 through 15 (of 29 total)
  • To elucidate on this it seems to be stripping out the part of the code that produces the video. This is the way posts come out on TypePad:

    <p>Here's a vBlog post about that new <a href="" series="P15D">Fujitsu P1500 convertible Tablet PC</a> that I've been raving about.<br /><br />

    <iframe src=";buffer=5&amp;fc=FFFFFF&amp;pc=CCFF33&amp;kc=FFCC33&amp;bc=FFFFFF&amp;;player=vp24" height="210" width="246" frameborder="0" scroll="no" scrolling="no"></iframe></p>

    And this is what shows up in WordPress 2.0 when we did the same thing with just “blah blah” text:

    <p>blah blah</p>

    We’ve also had trouble with javascript being stripped out. Is there any way to stop that? This guy had a working blog with audio and video at TypePad, now he can’t do half the things he used to do. Please help.

    I’m pretty sure I remember some posts to the testers list on this problem. You might dig through the archives for December….

    It’s not just Audioblog… I uploaded a video to the site and used the embed command with the html editor to include the video. The editor strips out the embed command.

    Here’s the post:

    Ever had a day like this? When everything you do at the keyboard goes wrong?
    That’s why this golden oldie video is so much fun to look at. It’s supossed to be surveillance shots of a frustrated office worker. Seems I later heard – after it was widely circulated online – that it was a hoax aimed at marketing surveillance cameras. No matter. Somehow, just watching this guy do what we all want to do sometime makes me feel better.
    <embed src=”” width=”320″ height=”256″ align=”middle”></embed>

    I used the html editor for the <embed src=”” width=”320″ height=”256″ align=”middle”></embed> code but, when I hit update… it’s not there. Then when I go back to the edito, all the embed code is gone.

    I’m heading to Las Vegas next week and hoped to video blog from the Consumer Electronics Show.

    Any ideas???? Thanks!

    A couple of ideas. I embed video on my site at and

    1. Don’t use the rich text editor when dealing with embeds. For whatever reason it blanks out the embed code. Whenever I want to insert or edit a video embed I just use the plain text editor.

    2. Try pasting something like the following code into the post:

    For Quicktime

    <embed src=”path/to/poster frame” BGCOLOR=”000000″ BORDER=”0″ width=”320″ height=”256″ autostart=”false” loop=”false” controller=”false” href=”path/to/media” target=”myself” />

    For Audioblog

    <iframe src=”[audioblog video id];pc=CCFF33&kc=FFCC33&bc=FFFFFF&″ height=”210″ width=”246″ frameborder=”0″ scroll=”no” scrolling=”no”></iframe>

    Both of these methods work for me in WP 2.0

    Help me out with some dumb questions here 🙂

    Version 2.0 has the html editor… that is what I have been using for the embed code. You’re saying just type the code into the regular editor without clicking html?

    Audioblog does the code itself when I try to post from its site… how do I alter it?

    For QT…
    What’s the difference between “path/to/poster frame” and “path/to/media” target=”myself”

    Your sites are very, very cool.

    Hey… I turned off that editor and VOILA! … I am able to insert the embed code in for QT…

    Still can’t get Audioblog to automatically post from its site though.

    Any ideas????

    New info from Audioblog…
    They suggest:

    “By default, the WordPress code might not allow <iframe> html tags. You’ll have to find the config option where you can allow that. Many blog engines will filter inbound HTML content and most likely this is what’s happening here.”

    Can someone walk me through just how to do this???

    I’ve not seen anywhere in the config options that “implements” an ability to use iframes. And in fact, I tend to think it’s not really problematic: for instance, google loads adsense ads into iframes, and wp hasn’t any trouble with that at all.

    I myself don’t use audio or video (or even graphics, much), so I’m of no help with this whatsoever….

    Skippy? Podz? Any thoughts?

    That’s what’s so weird… iframe seems fine in the sidebars.
    But when I post from audioblog, all that coding is filtered out by wordpress.

    Here’s the coding that audioblog tries to post:
    <iframe src=”″ height=”210″ width=”246″ frameborder=”0″ scroll=”no” scrolling=”no”></iframe>

    But none of it appears.. only the text I write above and below the iframe code.

    What would cause that to be filtered out?

    And vkaryl, thanks so much for all you do on this forum. I’ve been a troll for two days now reading support requests and you are the glue that holds so much of this awesome commnuity together. I suspect you aren’t thanked nearly enough.

    Oh gosh. Thanks, pcmike. That’s MORE than kind of you to say!

    I’m ripping that code, and I’ll play on my own 2.0 blogs (one a virgin install over the RCs, the other a recent upgrade from 1.5.2 – which for the doubters out there went without a hitch and no problems showing up at all….)

    I’ll post back in a bit; I’ve got the zoo to feed first….

    I’m not sure about the automatic publishing with WP 2.0 since I haven’t tried that with 2.0 but it was working for me with 1.5. What I’ve been doing with WP 2.0 (because I knew that the wysiwyg editor would wipe it out) is turning off the rich editor option and then pasting the code into the post and saving. Not my preferred way of doing it but it gets the job done. In 1.5 I was using a wysiwyg plug in and if I wanted to edit a post with the iframe I would deactivate the plug in before editing and saving the post.

    the “path/to/poster/frame” part is only if you use some kind of a graphic that people see by default instead of the first frame of your movie. If you’re not doing that then that field would also be the path to your media.

    Also, I just tried posting from Audioblog to my WP 2.0 site and it didn’t work. That really sucks cause i know it worked in previous versions of WordPress. It would be great if Audioblog could at least generate the code for you to paste. It would be even better if Audioblog could work with WP developers to make this work.

    Okay. I’ve got it up and working here: Video and audio.

    What I did: I have a plugin I use for posting, CJB Quick Post from This lives in the sidebar, and is visible only to admin (or others if you tweak the js). I input the code I ripped from pcmike’s post above, and it works fine (ah, in FF1.5, which is the only browser I use….)

    So obviously, cutting the editor AND the regular post input out of the loop will work.

    It’s a nice plugin, clean and easy to implement….

    Okay… let me give that a try…
    I will need some hand holding… This is my first WP plug in to try.
    I have already disabled the rich text editor so… gulp…here goes with the CJB QUick Post….
    I’ve loaded it and activated.
    But what does this mean:
    “Add the call cjb_quickpost() where you would like the form to show up”

    What do I do now?

    Hang on pcmike…. I’m hunting down the actual code string to put in the sidebar (most logical place for it)….

    One worry…
    Audioblog is an app that does the post itself. In other words, I log into audioblog, upload my video to them, then they let me title and put some text in and they send the code, logging into wp and posting the video.

    The code that we’ve been sharing is what we grabbed from typepad, where audioblog automatically did the post..

    I don’t ever see the actual code. I post to my WP blog through them. The ony way I got the code was by going to a successful post on typepad and copying it there.

    If I have to manually enter code we’re back to square one.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘AUdioblog video post with 2.0’ is closed to new replies.