Support » Plugins » Audio Player not working in 2.7

  • Any one else having issues with audio player in WP 2.7? We can upload a mp3 but when we go to hit the audio player button, nothing appears. I have tried this in Firefox and IE 7 with the same result.



Viewing 15 replies - 1 through 15 (of 17 total)
  • I too would like to figure this out. We just moved to 2.7 and I didn’t realize the audio player wouldn’t work. We need a quick solution or we won’t have any content on our site!

    He seems to have a link to a 2.0 beta version, but the link doesn’t work.

    I had the same problem. I used the auto install under plugins and it seems that it installed the plugin with an incorrect path (wp-content/plugins/audio-player/audio-player). Once I moved all the files to the correct directory path (wp-content/plugins/audio-player) it started playing mp3s just fine, although the admin menu for the plugin doesn’t work anymore. I haven’t gotten around to figuring that out yet since it plays my mp3s just fine I’m not really worried about it.

    hey guys. Its working with the 2.0 Beta available here

    do anyone know how to disable enclosure to feeds?

    The player is working for me with 2.7. Is it possible to provide a little more detail about the problems you’re facing please?

    I tried uninstalling it and reinstalling it manually, but I still got the same problem in 2.7. To fix the problem, I copied the files from wp-content/plugins/audio-player/audio-player to wp-content/plugins/audio-player and now it works. I have not tried changing anything in the admin menu so I’m not sure if that part works though.

    I have a problem here. I’m using your plugin (downloaded/installed today) with WP 2.7 and for purpose of using with Sermon Browser (Version: 0.40.2). For some reason, where the audio player should show up – it shows blank and if you right click it shows “movie not loaded”.

    The path for audio folder is correct and verified. I’m using Flash 10 plugin, Firefox 3.


    Right below sermon title there is a Scripture verse to. Below the Scripture verse, there is blank space where you can right click to see the movie not loaded error message.

    Then, if you click a specific sermon (example: it shows a download link still, instead of player. Right click, same error.


    Audio player also not work for me, for posts published after upgrading to 2.7. See The player shows up in prior posts, but not the most recent post. have tried version 1.2.3 and version 2.0 beta of Audio Player, with same results. It doesn’t enbed the audio player at all in the recent post, nor does it create the necessary custom field for the post as it did before upgrading to 2.7.

    I also changed the path of the swf and js files, from the plugin source file and it worked.
    The line numbers should be changed are 162,408,416,420. just change “/wp-content/plugins/audio-player/…” to “/wp-content/plugins/audio-player/audio-player/…”

    if you don’t want to play with codes you can easily move the content of the audio-player directory in the audio-player directory, to the audio-player directory.

    In the admin screen, when you clicked “Check the plugin version” you can get a message “there is a newer version 1.2.3” but, if you downloaded the plugin from wordpress or the plugin homepage it is wrong you don’t need to update.Because there is a mistake in plugin source file.

    Why I do not obtain to place plugin of the audio one to player in wordpress? Fernando Abreu

    As mentioned in another post I also have problems to make use of the player. As soon as I do a post containing the mp3 command or link I see big white gap or space around the player. Seems like this


    mp3 player


    Anyone know some help? Thanks a lot in advance!

    Unfortunately, I don’t have the problem with the “double” audio-player folders. All of the code for my audio-player is in this path already:


    Oh this is so frustrating. It worked FINE before the upgrade to 2.7. Buddies of mine who are also using 2.7 are having NO problems.

    I am using Mandigo 4.0.1. With audio-player 2.0b6. The url is

    I found a fix on another thread! WOOOT!

    Here’s the link.

    Here’s the code for the fix:

    I saved this file and overwrote the current audio-player file and everything is BACK TO NORMAL!! YAYAYAY!!

    I had the same issue with 2.7. I put the code snippet in and no player appeared. The beta version that Sumit1988 mentioned seems to work great for me.


    I’ve had a similar problem. I used the autoinstaller and it uploaded “double” audio-player folders.

    My problem now is that I cannot delete the files. I’ve tried deleting the files from the WordPress Plugins page and I get an error message.

    And when I try deleting the file using RBrowser I get an error message saying “permission denied”.

    I’ve never had this happen with any other plugin. Can someone talk me through a way of either fixing or deleting the plugin?

    Thank you gailFOD.
    Its working.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Audio Player not working in 2.7’ is closed to new replies.