Support » Plugin: WooCommerce » Attributes on items not showing in admin

  • Hi,

    I’m having an issue on a couple of my woocommercer stores and can’t seem to figure out why or how to resolve it.

    I have many products with attributes on the item level like so:https://prnt.sc/q9ym01

    But when I go into products>attribtes all I see is color, none of the other item attributes are there: https://prnt.sc/q9ymeq

    Any idea how I can resolve this? I’d like to use the attributes for filtering and archive pages.

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Tseten D

    (@tibetanitech)

    Hi @anjoid,

    I understand you are having trouble locating the attributes listed in the product editor on the Products > Attributes page.

    It looks like the Attributes in the product https://prnt.sc/q9ym01 is added in the product itself by clicking the Custom Product Attribute. This would only be ideal if you have a product with unique variations as it adds the attributes to that one specific product.

    Attributes in Products > Attributes are global attributes. We recommend adding global attributes if you want to use those attributes for other products as well. Here is a link to our documentation to understand how it works: https://docs.woocommerce.com/document/managing-product-taxonomies/#section-6

    Is there anyway to make all custom attributes global?

    Plugin Support Tseten D

    (@tibetanitech)

    The easiest way is to add those custom attributes in global attributes via Product > Attributes. Once done, you can use those attributes whenever you need it for other products.

    Otherwise, you might have to write some custom coding to change the existing custom product attributes to global.

    Yea I’m trying to avoid having to recreate all my attributes and then re adding them to all my products. Was hoping there was a way to easily convert custom to global :/

    Thanks for the info!

    Plugin Support Tseten D

    (@tibetanitech)

    You’re welcome!

    I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.