WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » [Resolved] Attributes gone after reinstall

[Resolved] Attributes gone after reinstall

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Mike Jolley

    @mikejolley

    Thats what happens when you use the ‘uninstall’ function in WordPress. Your data is uninstalled (logically).

    ” (logically) “…Well actually the terms have shown up once I manually re-added the same attribute names. It leaves the product post type and it’s categories. As well as the terms were still retrievable so I’m not sure why it wouldn’t remember the attributes that were assigned to the products that it left there. I deleted it to fix this problem , which it did.

    Many plugins are uninstalled but retrieve the same settings once reinstalled. Plugins have to be uninstalled at times when flukes happen or for testing. I’m sure alot of people have to reinstall the whole thing for whatever reasons. Sometimes plugins have options on uninstall to remove all data ( which usually it still remembers the settings) or not. Other times there’s an export option for the plugins data. I’m surprised if you’re saying this was supposed to remove everything and doesn’t give a warning that a store owner should backup. Glad it didn’t work out that way.

    Similar: http://wordpress.org/support/topic/21-release-is-a-disaster?replies=9

    After you clicked ‘Delete’ in the plugins overview for the WooCommerce plugin, it prompts you with the following question:

    Are you sure you wish to delete these files and data?

    The button that you then clicked on has the following label:

    Yes, Delete these files and data

    The ‘data’ word implies that it does delete your data, in addition to removing the files. This is how WordPress actually recommends plugins to do this, so I’m sorry this wasn’t clear to you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Attributes gone after reinstall’ is closed to new replies.
Skip to toolbar