Support » Plugin: WooCommerce » Attribute variations not showing on the front end drop down menus

  • I have added attributes “Webbing Size” and “Webbing Color” each has several variations. I select variable product, add these both of these attributes. I check, “Use for Variations.” I click “select all.” I then click “Link all Variations” and they show up. I have also tried adding individual variations manually. The variations are enabled and I do have stock amounts set.

    On the front end what I get is two drop down options, one for each attribute. Except all I get is “Choose options…” I can NOT get the variations to load correctly!

    I have now tried from scratch with two totally seperate products and sets of attributes and variations.

    As a note, when I set it up for a simple product and add attributes and check “Visible on Product Page” all that show up are the first variations of each attribute.

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 15 replies - 1 through 15 (of 39 total)
  • Ugh! I have been having the same problem!

    Initially my variation menus were all working properly, but now I can only use some of them, and one always says “Choose options” but it isn’t giving any options. It is very confusing! I had 4 different attributes and many different variables so I assume WooCommerce isn’t meant to handle so many variations. I removed one of the attributes to reduce the number of variables, but it hasn’t helped.

    Let me know if you get this sorted out! I have spent a lot of time trying to fix it on my site…I’d hate to have to scrap the whole project.

    Well, I tried publishing it just to see. Lo and behold it worked when I published it. But not on the preview.

    I have been having the same issue. I’ve only set up a couple products, and I set them up exactly according to the instructions (add the attributes, save the page, set up variations…). They worked at first. Then they suddenly stopped working; when I click the dropdown menu on the front end to “choose an option” none of the options show up.

    Roy Ho

    (@splashingpixelscom)

    Double check you have added a price for the variations, not the product itself. You will see a faint message telling you that “price is required” in the price field of the variations. Without setting it, in the frontend you will only see the dropdown to select an option and nothing else.

    I have the same issue with variations for my products as well after the update. For some products I have “Choose variation”, for some – only one variation is shown and there is no possibility to choose another, but what is very strange – still some of the products do work properly with variations!
    All prices in variations are set, all products have been republished and double checked after the update – still lots of problems(

    Roy Ho

    (@splashingpixelscom)

    Well the only thing I can suggest is switch to 2012 theme and re-test. If it works there, it means your theme is not compatible and would need an update.

    ok, I’ve found the solution – I’ve disabled the Reviews and everything is okay

    “ok, I’ve found the solution – I’ve disabled the Reviews and everything is okay”

    That is not a solution; that is a bandaid.

    It’s almost acting like there is a variation without the proper data in it. Anyone have a WooThemes account that can investigate for a real answer?

    We ended up re-installing the theme and the plugin as we were having a couple other odd issues. Everything seems to be working fine now.

    @sally.wolleat- did you lose all of your work or have to reconfigure your site when you re-installed your theme and plugin? I am basically done with my website, I’m only trying to fix this variations issue and I don’t want to lose all of my work.

    @britwill – Fortunately it was at the beginning of our project, so we didn’t have much data to lose when we re-installed the theme.

    One thing to check before you worry about re-installing your theme: make sure you have a price entered in every variation for your variable products. The drop-downs will not work at all unless the variations are all entered correctly and have a price.

    Good luck!

    Thanks, sally.wolleat. One last question, have you had any issues with the site since you re-installed everything?

    Britwill – no, we haven’t had any problems since the re-install.

    OK, this was driving me mad too, but I figured out the problem.

    Go into your edit product page, click on ‘attributes’ in the product data box.

    Click each attribute (colour/size/whatever) and ensure the ‘Visible on the product page’ and ‘Used for variations’ are checked. Click save attributes, save your product.

    It worked for me at least, worth checking yours are enabled.

    After I updated my theme and the plugin, the same thing was happening to me. For some reason it wasn’t recognizing some of the attributes I already had so I had to basically update it on all my products by doing it all over again using the following instructions:

    1. Go to Products->Attributes-.
    2. Add the attribute Shape (for example).
    3. Then in the box of attributes to the right click “configure terms” next to Shape.
    4. Add the shapes that you would like to use.
    5. Now add/edit your product. Select variable product.
    6. Go to the attributes tab. From the dropdown menu in the bottom right corner select “Shape” and Add. Check both boxes “Visible” and “variation”
    7. Click the values dropdown next to Shape and select the shapes you want for the product.
    8. Go to the variations tab. Click Link all variations.
    9. Make sure that they are all checked as “Enabled”. And if you have stock management activated make sure you enter stock of 1 or more.
    10. Publish/Update to save.

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘Attribute variations not showing on the front end drop down menus’ is closed to new replies.