WordPress.org

Forums

WooCommerce - excelling eCommerce
Attribute variations not showing on the front end drop down menus (42 posts)

  1. afinstrom
    Member
    Posted 2 years ago #

    I have added attributes "Webbing Size" and "Webbing Color" each has several variations. I select variable product, add these both of these attributes. I check, "Use for Variations." I click "select all." I then click "Link all Variations" and they show up. I have also tried adding individual variations manually. The variations are enabled and I do have stock amounts set.

    On the front end what I get is two drop down options, one for each attribute. Except all I get is "Choose options..." I can NOT get the variations to load correctly!

    I have now tried from scratch with two totally seperate products and sets of attributes and variations.

    As a note, when I set it up for a simple product and add attributes and check "Visible on Product Page" all that show up are the first variations of each attribute.

    http://wordpress.org/extend/plugins/woocommerce/

  2. sixemkay
    Member
    Posted 2 years ago #

    Ugh! I have been having the same problem!

    Initially my variation menus were all working properly, but now I can only use some of them, and one always says "Choose options" but it isn't giving any options. It is very confusing! I had 4 different attributes and many different variables so I assume WooCommerce isn't meant to handle so many variations. I removed one of the attributes to reduce the number of variables, but it hasn't helped.

    Let me know if you get this sorted out! I have spent a lot of time trying to fix it on my site...I'd hate to have to scrap the whole project.

  3. afinstrom
    Member
    Posted 2 years ago #

    Well, I tried publishing it just to see. Lo and behold it worked when I published it. But not on the preview.

  4. sally.wolleat
    Member
    Posted 2 years ago #

    I have been having the same issue. I've only set up a couple products, and I set them up exactly according to the instructions (add the attributes, save the page, set up variations...). They worked at first. Then they suddenly stopped working; when I click the dropdown menu on the front end to "choose an option" none of the options show up.

  5. Roy Ho
    Member
    Posted 2 years ago #

    Double check you have added a price for the variations, not the product itself. You will see a faint message telling you that "price is required" in the price field of the variations. Without setting it, in the frontend you will only see the dropdown to select an option and nothing else.

  6. pansyflower
    Member
    Posted 2 years ago #

    I have the same issue with variations for my products as well after the update. For some products I have "Choose variation", for some - only one variation is shown and there is no possibility to choose another, but what is very strange - still some of the products do work properly with variations!
    All prices in variations are set, all products have been republished and double checked after the update - still lots of problems(

  7. Roy Ho
    Member
    Posted 2 years ago #

    Well the only thing I can suggest is switch to 2012 theme and re-test. If it works there, it means your theme is not compatible and would need an update.

  8. pansyflower
    Member
    Posted 2 years ago #

    ok, I've found the solution - I've disabled the Reviews and everything is okay

  9. siibeon
    Member
    Posted 2 years ago #

    "ok, I've found the solution - I've disabled the Reviews and everything is okay"

    That is not a solution; that is a bandaid.

    It's almost acting like there is a variation without the proper data in it. Anyone have a WooThemes account that can investigate for a real answer?

  10. sally.wolleat
    Member
    Posted 2 years ago #

    We ended up re-installing the theme and the plugin as we were having a couple other odd issues. Everything seems to be working fine now.

  11. Britwill
    Member
    Posted 2 years ago #

    @sally.wolleat- did you lose all of your work or have to reconfigure your site when you re-installed your theme and plugin? I am basically done with my website, I'm only trying to fix this variations issue and I don't want to lose all of my work.

  12. sally.wolleat
    Member
    Posted 2 years ago #

    @Britwill - Fortunately it was at the beginning of our project, so we didn't have much data to lose when we re-installed the theme.

    One thing to check before you worry about re-installing your theme: make sure you have a price entered in every variation for your variable products. The drop-downs will not work at all unless the variations are all entered correctly and have a price.

    Good luck!

  13. Britwill
    Member
    Posted 2 years ago #

    Thanks, sally.wolleat. One last question, have you had any issues with the site since you re-installed everything?

  14. sally.wolleat
    Member
    Posted 2 years ago #

    Britwill - no, we haven't had any problems since the re-install.

  15. crdunst
    Member
    Posted 2 years ago #

    OK, this was driving me mad too, but I figured out the problem.

    Go into your edit product page, click on 'attributes' in the product data box.

    Click each attribute (colour/size/whatever) and ensure the 'Visible on the product page' and 'Used for variations' are checked. Click save attributes, save your product.

    It worked for me at least, worth checking yours are enabled.

  16. mayaelious
    Member
    Posted 2 years ago #

    After I updated my theme and the plugin, the same thing was happening to me. For some reason it wasn't recognizing some of the attributes I already had so I had to basically update it on all my products by doing it all over again using the following instructions:

    1. Go to Products->Attributes-.
    2. Add the attribute Shape (for example).
    3. Then in the box of attributes to the right click “configure terms” next to Shape.
    4. Add the shapes that you would like to use.
    5. Now add/edit your product. Select variable product.
    6. Go to the attributes tab. From the dropdown menu in the bottom right corner select “Shape” and Add. Check both boxes “Visible” and “variation”
    7. Click the values dropdown next to Shape and select the shapes you want for the product.
    8. Go to the variations tab. Click Link all variations.
    9. Make sure that they are all checked as “Enabled”. And if you have stock management activated make sure you enter stock of 1 or more.
    10. Publish/Update to save.

  17. Britwill
    Member
    Posted 2 years ago #

    Thanks. It was actually a code error in the template that I was using, which the web developer had to fix.

    Does anyone know how to make you product page to come up as "List" view by default instead of the "grid" view?

  18. vikkiranag
    Member
    Posted 2 years ago #

    i tried to add variation in product page variation I have linked all variations but in the front end all variation are not showing up check all the variation in ADDITIONAL INFORMATION and check it in the vriation as well they are not complete and when i try to link variations the message pop ups comes up with 0 variations added because i already added 144 variation but the problem is 144 variations are added in admin page but not showing up in frontpage? now what i need to do check the both links in the category below
    http://eternalbeds.co.uk/product-category/mattress-divan-beds/
    VARIATIONS ARE SLOWING UP THE PRODUCT PAGE NOW :( i am really confused what should i do to get rid of these problems

    is it some sort of theme issue or woocommerce?

  19. Erling
    Member
    Posted 1 year ago #

    Dear mayaelious
    Thank you so much - exactly the precise instruction I needed :-)

  20. benweb
    Member
    Posted 1 year ago #

    I can not get this to work for my site - it just shows choose an option - it's blanco theme - any help would be great

    http://www.trendytotscouture.com/new/product/polka-dot-hair-clips/

  21. brett84c
    Member
    Posted 1 year ago #

    So my site needed dropdown menus for selecting "Size" and "Color" attributes. Nothing worked until I went to the "Variations" tab that's in the individual product edit page. I clicked on "Bulk Edit" drop-down then "Prices" and then entered a value in the pop-up. Works like a charm now.

    Don't think you even need to select "Bulk Edit" and "Prices", you just need to set a value in the "Regular Price" field and that should fix the errors, at least it did for me.

  22. ivynll
    Member
    Posted 1 year ago #

    I am having the exact problem like @benweb, I am also using blanco theme, I wonder if the theme is creating the problem! Variations are not showing at all, I tried almost every method I can find online already, I also added the regular price, and the instructions provided above, it just showed "0 variation added", please help.....

    http://paradisehug.com/?product=fluorescent-abstract-scarf

  23. zenzane
    Member
    Posted 1 year ago #

    @ivynll
    Hi,
    I see on your website that your product variations are working with the blanco theme, could you tell us how you made it work?
    Thanks!

  24. sleepymonk
    Member
    Posted 1 year ago #

    One issue I found is that you won't be able to select any variations (even if you've set attributes, configured terms and added variations) if your product is set to "private". Change it to public and the variation selections show up as well as the add-to cart.

  25. sleepymonk
    Member
    Posted 1 year ago #

    One thing I also discovered that's frustrating is that if you change the attribute name, the existing variations in the product will have extra fields and won't work properly - they have to be deleted and added again.

  26. zenzane
    Member
    Posted 1 year ago #

    Actually i found out that variables are not showing up if I put spaces in the text of my attributes..
    I am using the XMarket theme from eight theme (which is similar to the Blanco theme, both are designed by Eight themes). Does anyone use the Blanco or Xmarket theme for woocommerce and has a solution for this?
    Thanks,

  27. flyersfan48
    Member
    Posted 1 year ago #

    Is there a way to bulk add variations to all of your products without doing each one individually? For example, certain strings you would enter into a csv file to get it to work?

  28. zoncan
    Member
    Posted 1 year ago #

    Hi, zenzane I uses XMarket theme as well the reason I found is you can only use lowercase letters in your attribute's value don't use any uppercase letters

    for instance

    "item1|item2" is right

    "iTem1|iTem2" this will stop working

    Hope this helps

  29. timburkart
    Member
    Posted 1 year ago #

    Hi zenzane and zoncan, I too use the XMarket theme and need spaces in my variation names. I just opened a support ticket at 8theme. I'll report back with the results of my query.

    Thanks for your report!

  30. simonhunter
    Member
    Posted 1 year ago #

    Hi timburkart,

    Just wondering if you had had any response to your support ticket? The theme I'm using has the same problem - I can't put uppercase letters in the variations - I would like to find out how to fix it. Let me know if you've been able to figure it out. Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic