Support » Plugin: WooCommerce » Attribute filters appear inside an attribute archive?

  • Resolved stuart2020

    (@stuart2020)


    Hi,

    I have brands set up as attributes in my shop. When I am in the archive for a certain brand it shows filter boxes down the left as I’ve asked it to do on archive pages. However, it is suggesting that all the other brands are part of the brand which page I’m on. You click on one of the filter boxes that says it has say 10 results and it says there are none to display (correctly as i’m already inside an attribute for that filter)

    It’s hard to explain without looking – link above, Any help on how to remove this filter in this situation would be much appreciated!

    Thank you

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support RK a11n

    (@riaanknoetze)

    Hi there,

    I’ve just had a look at the link you provided and I’m seeing the following:


    Link to image: https://d.pr/i/UKvSON

    I’m not seeing the “Scribbly Bits” in the left-hand widget although I do see that the archive page is populating with products – Does this match with what you’re expecting to see? Can you share a screenshot of that widget setup as well as a copy of your status report under **WooCommerce > Status**?

    Thread Starter stuart2020

    (@stuart2020)

    Hi,

    Thank you for getting back to me. I’ve just changed the query type to AND instead of OR and that has resolved it, sorry thought i’d tried that.

    (Scribbly bits didn’t appear but all the other brands did, which shouldn’t be possible as I’m already in a brand. i.e, there aren’t 32 ‘Lanco’ inside ‘scribbly bits’ so it shouldn’t have shown that)

    Thanks

    Stuart

    Plugin Support RK a11n

    (@riaanknoetze)

    Aaah, perfect! Thanks for the feedback and glad to hear you got to the bottom of that 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Attribute filters appear inside an attribute archive?’ is closed to new replies.