Support » Plugin: WCP OpenWeather » Attention! OpenWeatherMap changed conditions of FREE API ussage!

  • Plugin Author WebCodin

    (@webcodin)


    Dear Customers,

    Attention! Unfortunately, OpenWeatherMap changed conditions of FREE API ussage!

    OpenWeatherMap API doesn’t work without API key any more.
    You need to add free or paid API key in the plugin settings: WCP OpenWeather > Settings > API Key.
    You can get API key here: http://openweathermap.org/appid#get.

    In additional, we want to pay your attention on that fact that OpenWeatherMap changed conditions for FREE API key ussage – they downgraded value of calls per minute to 60. You can check it here: http://openweathermap.org/price.

    Based on this we reccomended to set plugin “Refresh Time” option (OpenWeather > Settings > Plugin > Refresh Time) to reccomended value (1h) or more.

    With kind regards,
    WebCodin WordPress Team

    https://wordpress.org/plugins/wcp-openweather/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thank you for the update.

    Are calls measure on page load/refresh?

    Cheers

    Hi, I noticed the plugin stopped working on my website a couple of days ago and just came across this notice.

    I registered to receive my free API key and I then added the key to the plugin settings, but the plugin is still not working. I then tried resetting the API key and put the new key in the plugin settings, but still no success.

    Plugin Author WebCodin

    (@webcodin)

    Hi austin69,

    Could you please try cleanup cache and cookies.
    If it won’t help, could you pls send link on your site here or directly via support@webcodin.com and value for OpenWeather > Settings > Plugin > Refresh Time?

    Plugin Author WebCodin

    (@webcodin)

    Hi sergioal,

    We’ll provide answer on your question in the topic that you oppened.

    Hi, I just checked my website again and it now seems to be working. I never did anything new on my end, but it now works. My refresh time is set to 1 hour. Thanks.

    Hi!

    I couldnt make this plugin work for free. At work we have an intranet for only the members of the organization and we had included OpenWeatherMap. It was working great until October.

    I put in the plugins options -> OpenWeatherMapsAPPID: http://api.openweathermap.org/data/2.5/forecast/city?id=3843123&APPID=bd82977b86bf27fb59a04b61b657XXXX ,
    where id=3843123 is Neuquen,AR
    and “bd82977b86bf27fb59a04b61b657XXXX” is the APPID that give us at the registering moment.

    Then in the widgets options Aweasome Weather Widget, we put the same in OpenWeatherMap City ID: http://api.openweathermap.org/data/2.5/forecast/city?id=3843123&APPID=bd82977b86bf27fb59a04b61b657XXXX

    Any help is welcome 🙂 . Sorry about my english XD.
    Thanks !

    Plugin Author WebCodin

    (@webcodin)

    Hi sebamsg,

    We’re sorry, but we are do not quite understand your issue. Our plugin does not have described settings.
    Our plugin has only one option for API key, you can find this option in the plugin settings: WCP OpenWeather > Settings > API Key. Also you are not able to use city ID for city definition in our plugin.
    Are you sure that you asked right plugin support?

    With kind regards,
    WebCodin WordPress Team

    hi webcodin,
    i made it work! jeje thanks!

    i was making mistakes in the fields i have to fill

    thanks again. regards!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Attention! OpenWeatherMap changed conditions of FREE API ussage!’ is closed to new replies.