Support » Fixing WordPress » Attempted to fix “array key” issue – created more problems

  • Hi There,

    While I have been using WordPress for a while I am not a coder in any sense of the word. I can follow direction though and I’m willing to try anything.

    Today I attempted to add a small block of HTML code in the Text widget, I did something wrong with the code and I received an error, Warning: array_keys() [function.array-keys]: The first argument should be an array in

    I searched on this site and followed the suggestions to fix the problem, some did not work at all, so I went down the list trying new things. When I tried,

    // define(‘DB_CHARSET’, ‘utf8’);
    // define(‘DB_COLLATE’, ”);

    I put a /* before and after the above code each line,

    This did something! When I went to log into my wp-admin what came up on the screen was as though I had just installed WordPress!!!

    In order to keep my users from making any changes I quickly added my blog info.

    All of the files are still on my server. The question is how do I associate all the Database files?

    I don’t want to make a mess (I think I’m too late!) But I would appreciate some help so I can get my site back up!

    Thank you.

Viewing 1 replies (of 1 total)
  • I went into my FTP site and deleted and replaced both the wp-admin and wp-includes folders from a back-up.

    I had accidentally put my updated wp-config.php file in the wrong place!!

    After deleting the old wp-config file and installing the updated file the site was back up and running. Unfortunately the original problem was still there.

    Which was the “Warning: array_keys() [function.array-keys]: The first argument should be an array in ” problem. I re-read the post here –

    And discovered that I had missed the post by Otto42. I went back and followed his directions. Since I was unable to get into my wp-admin page I edited my database as instructed.

    If you go and edit all your text widgets and then save changes, this should go away. Worst case, manually edit your database, find the widget_text row in wp_options, and remove it. Then put your text widgets back.

    This solved the problem. Before trying anything else to resolve the array issue, please try this first!

    Thank you Otto42!

Viewing 1 replies (of 1 total)
  • The topic ‘Attempted to fix “array key” issue – created more problems’ is closed to new replies.