Support » Fixing WordPress » Attempt to update Jetpack 1.9 to 1.9.1 hangs site

  • Resolved dde7


    My WordPress 3.4.2 blog website has hung repeatedly when I attempted to update Jetpack 1.9 to 1.9.1; I don’t recall this ever happening before when I tried to update Jetpack or any other plugin (I also use XCloner and Social Login). I recently posted a guest post on behalf of a famous and popular author, including a link to a PDF version of the post available for download, so site traffic is likely to be much higher than usual. (This post is currently the only one on the site, so it is easily accessible from the home page.) The site becomes available again a few minutes after each failed update attempt. The message from trying to visit the site’s home page or Dashboard when it is hung is:

    Briefly unavailable for scheduled maintenance. Check back in a minute.

    After some, but not all, failed update attempts, the following message appears on the Update page:

    500: Internal server error
    This error is generated when a script running on the server could not be implemented or permissions are incorrectly assigned for files or directories
    Troubleshooting suggestions:
    Temporarily disable any rewrite rules by renaming your .htaccess file if it exists.
    Ensure that any CGI or Perl scripts have at least .755. permissions.
    If trying to run PHP and you get this error, you may have an invalid php.ini in your /cgi-bin, or may be missing your php.dat file in this folder.

    When I revisit the Dashboard after the site comes up again, I get the following message in yellow at the top of the screen:

    An automated WordPress update has failed to complete - please attempt the update again now.

    I have not yet followed any of this boilerplate advice; I doubt seriously whether any of it has anything to do with the actual causes of the crash, especially since I have not changed any of the things it mentions since previous successful updates of plugins, including Jetpack. The only relevant change I am aware of is the posting of the guest post referred to above.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Never mind; it finally updated successfully to Jetpack 1.9.1 after yet another attempt. I hadn’t changed anything; I just kept trying to update.

    Mine is still doing this. Who are you hosting with? Mine started after NetworkSolution’s hosting debacle blamed on Sandy.

    I can’t update my Jetpack and receive the same error.

    I’m also hosting with Network Solutions! And I’m noticing site slowdowns, although the update finally went through. Thanks for posting; it had never crossed my mind that this could have anything to do with Hurricane Sandy. Do you have a link with more information about the hosting debacle you refer to? If so, please post it!

    I encountered this problem updating Jetpack recently. I couldn’t get into the dashboard to attempt to update it again. I had a “briefly unavailable due to maintenance” error as well just after running a couple updates – one for JetPack and one for PageLines theme.

    Googling the error first gave me the suggestion to delete the .maintenance file in the public_html folder. It wasn’t there.

    Then I looked more and found this post. It let me know that the JetPack update could possibly have failed.

    Then I went into the file manager and moved the \wp-content\jetpack folder into another folder. I was then able to get into the dashboard and my website started working. The theme was intact, so I gathered the problem was actually with JetPack and not PageLines theme update.

    I attempted to do the update again by clicking on the error at the top of the dashboard, but saw no activity. While I had the dashboard up, I moved the folder back and everything seems to be working.

    Don’t know what I did that really “fixed” it, but at least my website is back up and working.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Attempt to update Jetpack 1.9 to 1.9.1 hangs site’ is closed to new replies.