Support » Plugin: Edit Flow » Attempt to Assign Property of Non-Object Warnings

  • Hello,

    Since I installed the latest version of WordPress to 3.7, the Edit Flow plugin has been posting warnings every time I go to view the posts area. It breaks my installation actually.

    Here are the screenshots:
    This image is of when I am logged into the admin panel and just clicked on the Posts section.

    This image is of me scrolling down the Posts section and you can see the warnings for every post.

    I have no idea what is causing this but I’ve had a few problems since the update of WordPress with other plugins such as WordPress SEO. I had to uninstall Edit Flow and WordPress SEO until these issues get fixes. WordPress SEO was literally breaking my website with white screen and warnings.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author cojennin


    Odd. What other plugins do you have installed (other than WordPress SEO), and what sort of theme are you using?

    I am using the Made Theme by Industrial Themes from Themeforest. This theme last updated a couple of months ago.

    The plugins I recently installed right before I upgraded WordPress:

    Comments Evolved for WordPress
    Jetpack by

    Before these two plugins were installed, I had Edit Flow installed and it was working fine including having WordPress SEO installed.

    WordPress SEO is now working after I deactivated, deleted and optimized my database and then reinstalled but Edit Flow is not. I deactivated, deleted and then optimized database and reinstalled but I still get the same warning errors breaking my website.

    Plugin Author cojennin


    Strange. What sort of custom statuses do you have right now? Have you modified them in any way (maybe some don’t have a description, etc)? Just curious since it seems to be an issue with the custom status functionality.

    It broke my website so I had to deactivate it and then I deleted it and reinstalled it. Whatever custom statuses was there, it’s no longer there and that wasn’t the problem because the plugin settings was wiped out. When I reactivated it, the same problem happened. releases a new update for installation. I’m going to update and then reactivate the Edit Flow plugin to see if it works.

    Will post again after this process.

    Edit: I thought by deleting the plugin, it would remove any settings there, but it did not. Therefore my custom statuses remained intact and the same errors came back after updating WordPress.

    So I listened to last recommendation about custom statuses and just deactivated the module. The rest of the plugin seems to work fine now.

    I still don’t know what is causing the plugin to produce a post custom status error.

    Plugin Author cojennin


    Odd. It may be theme related (I know another user was reporting an issue they were having which also involved the Made theme). Unfortunately, given that it’s a premium theme I can’t really work on triggering this issue. I’ll continue to try and debug on my end (I pushed a “fix” which just adds another check if any custom statuses exist, but I’ll take a stab and say the theme may be manipulating a filter or action dealing with terms that affects Edit Flow in some fashion, causing that bug).


    It could very well be my theme since the last update for it was a few months ago. Should I post my errors on their support forum as well?

    Thank you!

    Plugin Author cojennin


    Definitely wouldn’t hurt. If they figure out what’s causing the issue, definitely post back here. I’d like to fix if possible.

    Hello cojennin,

    I’m receiving email correspondence from the developers now and so far they have said it sounds like a plugin issue, but I will post exactly what they are saying when I get a full detailed reply back after linking this thread to them.

    Thanks again!

    I have new correspondence.

    The response from Made theme developer after giving him all information:

    On 11/7/2013 9:44 AM, Brian McCulloh wrote:
    > Thanks, let me know if it ends up being anything related to the theme. Quick question: what version of WordPress did you update from? Also, have you tried it with edit flow being the only plugin active? One other thing just to be sure, did you try re-downloading a fresh copy of Made from ThemeForest and overwriting all of your current theme files just to rule out any file corruptions? You wouldn’t lose any content or settings if you did this, only modifications directly to any theme files, if any.

    My responses to his questions:

    1. I updated to WordPress 3.7.1

    2. I deactivated all plugins, then I activated edit flow only to test it. The same warning errors appeared when I reactivated the module for custom post statues. The other modules work fine.

    3. I believe I re-installed a fresh copy of Made but I can try that again to see if it works. I do have some modifications in the theme files such as analytics. Also wouldn’t I have to deactivate all plugins again so that their integration would go into the fresh install of Made theme?

    I honestly don’t think its a theme problem because like I said, right after the update, some plugins went awry. But I’ll try it and see.

    So in the end, I can upload a clean copy of Made theme and overwrite files but I do believe this is a plugin issue.

    Since I recreated the problem, it lies with the custom statues module in Edit Flow. The other modules work fine. Please look into this.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Attempt to Assign Property of Non-Object Warnings’ is closed to new replies.