[resolved] attachments and api query links showing up in bibliography as extra sources (4 posts)

  1. benmiller314
    Posted 3 years ago #

    Let me first say how excited I am by this plugin, which I've never used before but have long admired from afar. I'm eager to begin playing with the in-text citation features. But first, I want to get the basic library appearing properly on-screen.

    Running WP 3.5 and Zotpress 5.0.4, I'm trying to display a group library on a Page. With help from other forum entries, I successfully added the group account by entering the groupID in the User ID space on the Zotpress account screen; I then imported the library, which currently has 15 items in it. These 15 items show up correctly on Zotpress Browse. (The links to sub-collections do seem to be thrown off by our local WPMU subsite structure, such that they try to access a library at the root page rather than my individual site, but when I correct the URL the sources are all where they should be.)

    However, when I enter the shortcode [zotpress userid="%myuserid%" sortby="author"] on a page, I get far more than 15 items. Some of them appear to be attachments, such as notes, that have floated free from their parent sources; others appear to be api query links, of the form https://api.zotero.org/groups/139482/items/PTNT59JI (though now that I look at the xml output, maybe that's also an attached file).

    You can see this happening at http://macaulay.cuny.edu/eportfolios/macbride13/annotated-bibliography-via-zotpress/.

    I've searched the forum, and I can't find any other reports of this behavior, at least not on a recent version of Zotpress. It's not the sortby, because it also happens when I remove that. I've tried re-syncing and clearing the cache, re-importing and clearing the cache, and nothing's changed. (In fact, even after the resync it's still showing a source that I'd removed from the group library in Zotero.)

    Any guesses?

    Many thanks in advance,


  2. Katie
    Plugin Author

    Posted 3 years ago #

    I think this is expected behaviour -- what happens when you add in the datatype attribute, e.g. datatype="items" ?

  3. benmiller314
    Posted 3 years ago #

    No change, as far as I can tell, from adding datatype="items".

    Next I tried displaying just one collection, using the syntax on the help screen and a collection ID from the Browse screen, and the bibliography came up empty. Does that suggest an incorrect setting somewhere? In making the private key, I unchecked all the personal library options, and set the group option to Read/Write.

    When you say it's expected behavior, do you mean the part about the attachments, or the part about the api links?

  4. Katie
    Plugin Author

    Posted 3 years ago #

    Nope, the API links are definitely bizarre. Could you contact me privately about this? I'll have to take a look. http://katieseaborn.com/contact

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.