Support » Plugin: DCO Comment Attachment » Attachment won’t upload

  • Resolved reallango

    (@reallango)


    I’m having trouble getting this plugin to work on my site.

    I’m using the Twenty Seventeen Theme with a few code snippets and personal modifications to get it to look like I want. I have been able to track down the code snippet that seems to be causing the problem and wanted to see if they can be made to work together or if you have a suggested work around.

    The following code snippet removes the previous and next post link from the bottom of the posts.

    function remove_link( $format, $link ) {
        return false;
    }
    add_filter( 'previous_post_link', 'remove_link' );
    add_filter( 'next_post_link', 'remove_link' );
    • This topic was modified 6 months, 2 weeks ago by reallango.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Denis Yanchevskiy

    (@denisco)

    Hello @reallango,

    Your snippet throws error “Fatal error: Uncaught ArgumentCountError: Too few arguments to function remove_link(), 1 passed and exactly 2 expected”.

    Try this:

    function remove_link( $format, $link ) {
        return false;
    }
    add_filter( 'previous_post_link', 'remove_link', 10, 2 );
    add_filter( 'next_post_link', 'remove_link', 10, 2 );
    Thread Starter reallango

    (@reallango)

    You my good sir are awesome! Worked like a charm.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Attachment won’t upload’ is closed to new replies.