Support » Plugin: Yoast SEO » Attachment page indexing disaster

  • Resolved mivabeuy

    (@mivabeuy)


    Since we’ve Yoast installed on our page a couple of month ago we had no problems, but with one of the last updates the disaster begun – unfortunately we didn’t realize it immediately.

    We didn’t notice that the option to redirect the attachment pages to their parent was gone and the other redirect to the original media file option was set automatically to NO!!! Now we have 12.000!!! indexed pages and this affected our ranking results catastrophically. It’s really a disaster for us! We can’t understand how this could happen just with a plugin that normally should optimize SEO and not the contrary.

    Now we began to delete this indexed pages manually in the search console. Each time the most we can delete at once until reaching the limit. Will take ages! But I’m afraid that won’t be enough because this process will eliminate this pages just for 90 days from the index. After that time the pages will be indexed again, if we don’t make sure to avoid this. Our fist action was to set a disallow for this pages in the robots.txt

    Allow: /immobilien/*/$
    Disallow: /immobilien/*/*/$
    Allow: /en/properties/*/$
    Disallow: /en/properties/*/*/$
    Allow: /es/propiedades/*/$
    Disallow: /es/propiedades/*/*/$

    It works, but we are not sure, if this is the right way.

    We’ve already seen that we are not alone with this big, big problem. Somebody solved it and could be so kindly to tell us what to do?

    Thanks in advance!

    • This topic was modified 1 year, 9 months ago by mivabeuy.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m having the same issue here, after last update all my images being indexed – That’s my site https://seguridadsocialweb.com

    Plugin Support Michael Tina

    (@mikes41720)

    @marinaperez @mivabeuy

    We apologize for any inconvenience caused. Since the release of Yoast SEO v7.0, we removed the ‘redirect attachment URL to parent post’ and replaced it with ‘redirect from attachment URL to the attachment itself’. We suggest changing the settings in Yoast SEO to either ‘redirect from attachment URL to the attachment itself’ or if you wish to keep the attachment pages, you can set it to not redirect and make it not show in the search results. Once you’ve made the necessary settings changes, please give some time for Google to reflect the changes in the search results. You may also want to resubmit your sitemap.

    Guys, I am a little confused as to if I have a problem.. I am using version 7.5.1 and my media attachment url settings are set to yes…. i obviously do not want images appearing in serps, because of the possibilities of reduced rankings and even penalties for thin content…. what is the correct setting i need to use – Yes Or No… also if i need to change the setting, should i then resubmit my sitemap

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    If you want to redirects the media (attachment) pages, you can set YES, if you don’t but not want to see media (attachment) pages in the search results, you can set NO. Both of these options are fine and depends on your needs.

    Hey @mazedulislamkhan it’s good to have some clarity with the setting.

    Can you also please clarify that your advice is resubmitting the sitemap will (over time) resolve the problem of literally hundreds (and for some people thousands) of images being indexed by Google?

    And if so, can you advise how long you think it take Google to de-index all the images that have been mistakenly indexed due to this update?

    If there are any other actions users can take to more quickly resolve the problem of images being indexed on google unintentionally it would be good if you could advise.

    Plugin Support benvaassen

    (@benvaassen)

    We have released a new post explaining things in detail: https://yoast.com/media-attachment-urls/

    I’d give that a good read and follow the advice we provide. Let me know if you have any questions after reading it. We are happy to help.

    First of all thanks for shi..ng on my website and the answer that i got from y… was “you are not a premium…” after this crapy update came with a disaster, more then 12k images… how can i fix this by disallowing attachment id ? in robots.txt

    Regards

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Attachment page indexing disaster’ is closed to new replies.