WordPress.org

Forums

Yoast SEO
[resolved] Attachment Page 404 Errors (3 posts)

  1. tizz
    Member
    Posted 2 years ago #

    This is a relatively new problem to me.
    I used this plugin for a while, but only recently I reported a large number of 404 errors for attachment pages.
    I don't know if it started after a plugin update (not 1.4.13 anyway, maybe one or two updates before), but most likely it started after I checked the "Redirect to the URL of the post attachments parent" option.
    Also, in the sitemap I checked the option "media" to exclude this post type, and in fact the map isn't created, but google webmaster tool gives sitemap as the source of not found url http://mysite.com/attachment/
    Do I have to include the media post type in the sitemap then?

    I tried to update the SEO and WP permalink pages, and I have included in the robots.txt Disallow: /attachment/ but the pages are still
    scanned and gives a 404, so it seems that the redirect doesn't work at all.
    I haven't tried to select "noindex" under "media" in Titles & Meta because I doubt that it's the right thing to do.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. tizz
    Member
    Posted 2 years ago #

    /attachment/ 404 error pages are going on and I don't know how to stop it.
    Maybe I have to uncheck the redirect, but I'd like that option if it worked.

  3. tizz
    Member
    Posted 2 years ago #

    Maybe it's because I've changed names to several photographs, I'll take a look at.

    EDIT: Yes, I didn't remember that name-changing-thing, but I think that's the reason. They are real 404s.
    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic