Support » Plugin: Gravitate Encryption » Asymmetric Encryption issues

  • Web Maker

    (@cottagecrafted)


    Hi there!

    Quick question on Asymmetric Encryption: It seems that when I have only the public key in, everything shows as XXXXX, like it should. However, when both private and public keys are entered, the entries end up totally blank. I’ve copied/pasted the keys from my key emails. Am I doing something wrong?

    Thanks!

    https://wordpress.org/plugins/gravitate-encryption/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Web Maker

    (@cottagecrafted)

    Hi there!

    We’ve been waiting for a week on this issue now. Could we please have a response? We like the promise of the security of this plugin.

    We’ve checked and double checked the process and it is not working per your instructions. Using Asymmetric Encryption, as you have said is stronger, thus encrypting that data in the Admin, is what we are trying to simply accomplish. If our process is wrong or if there are other steps in Asymmetric Encryption that we need to execute, please let us know. If there is a fix, we would appreciate your help.

    Plugin Author Gravitate

    (@gravitate)

    Unofortunately, we have not run into this issue before.
    Can you provide more information.

    What version of the plugin are you using?
    What version of WordPress are you using?
    What version of PHP is your server running?
    Can you confirm that your server is configured with mcrypt properly?

    Web Maker

    (@cottagecrafted)

    We are using:

    Gravitate Encryption version 1.0.4
    WordPress 3.9.1
    PHP: 5.4.4

    Our host said both libraries were up. He asked “What am I looking for when you ask me to double check configuration? Which specific questions are being asked by the plugin developer?”

    BTW, does mcrypt affect openssl?

    Hey,

    I’m having the same problem as @cottagecrafted described above and I’m using the same configuration.
    Does anyone have a solution on this ?

    Thanks.

    dhefley

    (@dhefley)

    I had the same issue. Turns out it was a private key that needed to be wrapped in the:

    —–BEGIN PRIVATE KEY—–

    and

    —–END PRIVATE KEY—–

    lines.

    When we looked at the php error log, openssl_open complained about not being able to coerce parameter 4 into a private key.

    Plugin Author Gravitate

    (@gravitate)

    That is correct. Those lines are required. With no space before or after.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Asymmetric Encryption issues’ is closed to new replies.