Support » Plugin: Custom Adobe Fonts (Typekit) » Astra attempts to load TypeKit font from Google

  • Hello,

    I’m using this plugin on my site and was inspecting a page in Chrome when I noticed a console error.

    Here’s the error:
    “Failed to load resource: the server responded with a status of 400 ()”

    Here’s the recourse in question (shown as tooltip when I hover over the link for the error in the console): https://fonts.googleapis.com/css?family=Filson-Soft%3A400%2C&ver=1.6.2

    Filson-Soft 400 is a font in my kit that I’m using with this plugin, and I’ve set it as the default font in Astra’s Typography options. As you can see, Astra is attempting to load it from Google, resulting in an error.

    Just to make sure this wasn’t being caused by any plugin conflict, I created a test WP site, on which I only installed Astra as the theme and Custom TypeKit Fonts as the only plugin. I then loaded my TypeKit in the plugin’s settings, went to Customize > Typography > Base Typography and set Filson Soft with the weight 400 as the default font, and loaded the site to inspect it. The same error was in the console.

    You should be able to reproduce this error using the exact same way on a fresh install.

    The error can also be seen when testing the website with GTmetrix, WebPageTest or any tool that shows a waterfall view or list of resources loaded.

    Even though the actual font is still loading from TypeKit and works fine on the frontend, this one extra request to Google Fonts that results in an error is what’s bothering me.

    Can you please fix this?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.