WordPress.org

Support

Support » How-To and Troubleshooting » Assigned page in reading settings for posts not using the correct template?

Assigned page in reading settings for posts not using the correct template?

  • Hi guys,

    I’ve used the reading settings to set up a static front page and a blog posts page to show the latest entries, the front page displays correctly.

    It uses the custom page template I’ve used, but for the blog posts page…which is also a custom page template WordPress doesn’t recognize the template for some reason, it uses Index.php instead.

    <?php
    /*
    Template Name: Blog Front Page
    */
    ?>

    Even though I’ve used the above snippet at the top of the code in the custom template for the blog page?

    I’m confused why WordPress doesn’t want to accept the blog page template and uses Index.php instead.

    Is it because the Readings settings doesn’t accept a custom template for a blog posts page?

    That would be odd though because it does accept a custom template for the home page.

    Something isn’t right and I can’t put my finger on it, your help is much appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Yes, your main blog page will use index.php. The Page templates are only for Pages. In this case, the “Page” you’ve assigned your blog to isn’t actually a Page at all, but just a placeholder for your blog.

    So you’ll need to edit your index.php file to do what you want, not try and use the Page template.

    Okay thanks! 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Assigned page in reading settings for posts not using the correct template?’ is closed to new replies.
Skip to toolbar