Support » Plugin: Asset CleanUp: Page Speed Booster » Asset Cleanup with Autoptimize

  • hey

    i just need disable cache from functions.php of theme

    my problem i just need filter files like css , js from Asset Cleanup only

    but im not enable CSS Files Minification but it enable

    i see file in my code

    cache/asset-cleanup/css/item/main_stylesheet-v4.7.5-6277a0340f4a716718380990a296c4e364db308f.css

    and cache is disable only plugin Autoptimize

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Gabe Livan

    (@gabelivan)

    @c0der

    i just need disable cache from functions.php of theme

    I’m not sure what you meant by that. What type of caching would you like to disable from functions.php? Besides Autoptimize and Asset CleanUp, do you use any caching plugin such as WP Rocket or your hosting offers a page caching option that is already activated for your package?

    but im not enable CSS Files Minification but it enable

    Is the CSS minification in Asset CleanUp enabled or not? Is it deactivated, but the file is minified anyway?

    i see file in my code
    cache/asset-cleanup/css/item/main_stylesheet-v4.7.5-6277a0340f4a716718380990a296c4e364db308f.css

    That file is created and stored in the Asset CleanUp’s caching directory whenever the contents of the file is altered (e.g. minified). When retrieved, it’s faster to read it from the caching (already optimized), then re-optimized it on the fly (do the minification and any other changes as it takes longer time).

    Thread Starter elfnon, inc.

    (@c0der)

    only i use Autoptimize and plugin to defer js

    so only need active hide js and plugin from site but Asset CleanUp cache all with file main_stylesheet

    what i want to do in functions.php of theme file disable all cache Asset CleanUp

    becuze it break my site and option is disable but it cache site ^_^

    Thread Starter elfnon, inc.

    (@c0der)

    any help
    @gabelivan

    Plugin Author Gabe Livan

    (@gabelivan)

    @c0der sorry for this late reply! I couldn’t understand your query initially and couldn’t help you out at the time! Plus I was busy with the releases of the latest tags, hopefully you upgraded by this time.

    only i use Autoptimize and plugin to defer js

    Are you saying you use Autoptimize to defer JS or you use both Asset CleanUp and Autoptimize to defer JS. It’s not very clear what you meant by “i use Autoptimize and plugin“.

    so only need active hide js and plugin from site but Asset CleanUp cache all with file main_stylesheet… what i want to do in functions.php of theme file disable all cache Asset CleanUp

    Can you be more specific about “only need active hide js and plugin“? As for the caching, Asset CleanUp stores any altered file (e.g. via minify feature) within /wp-content/cache/asset-cleanup/. This is done whenever a file needs to be altered via the plugin. It can’t be disabled as it’s required for the functionality of the plugin (doing changes “on the fly” would take longer time to render and since this is a performance plugin, a cache system for reading files faster had to be implemented). The plugin will stop writing anything to /wp-content/cache/asset-cleanup/ if you have all of the following features inactive: minify/combine CSS/JS, add “font-display” to Google Fonts font-face (basically it requires an alteration of the CSS file, and thus it stored its modified version to the cache directory).

    Thread Starter elfnon, inc.

    (@c0der)

    thanks @gabelivan for reply

    what mean about “only need active hide js and plugin”

    after i disable CSS Files Minification and js Files Minification

    i see file main_stylesheet

    but now after disable plugin and enable again it not create main_stylesheet

    but if i delete same css it create main_stylesheet or not?

    Hi @gabelivan !

    I have the same problem.

    I just want to use Asset cleanup to cleanup assets, cause I use antoher plugin to minify/cache…

    I have deactivated css and js minification/combination/defer, but the plugin still is generating cached versions.

    I reinstalled the plugin reset all my settings, but nothing helps. I can´t disable the features.

    • This reply was modified 2 years, 2 months ago by docbt.
    • This reply was modified 2 years, 2 months ago by docbt.
    • This reply was modified 2 years, 2 months ago by docbt.

    I could resolve the problem by activating minify/combine and enabling the debug option (only for Admin). After that I deativated minify/combine again.

    hello @gabelivan

    @docbt clearly identified the problem.

    I have deactivated css and js minification/combination/defer, but the plugin still is generating cached versions.

    this is the problem. Even if we disable minification/combination/defer in asset cleanup, asset cleanup still generates some files.

    Plugin Author Gabe Livan

    (@gabelivan)

    @docbt @belgen Asset CleanUp could generate cached files even if you have minification/combination/defer deactivated. Whenever a file has to be changed, a cached version has to be created (it doesn’t get generated on page load, that would require too many resources used and also a long time to render the pages, hence, caching is used, that’s how many plugins work).

    To understand how the files are generated in the caching directory, please check this post: https://assetcleanup.com/docs/how-css-js-are-created-within-the-caching-directory/ – it explains the other settings (not just minify/combine) that could lead to the generated cache files.

    Thread Starter elfnon, inc.

    (@c0der)

    @gabelivan can make process Asset CleanUp check frist Autoptimize and make him last process

    or we think how to fix this cuz alot of plugins not work good

    I am having this exact same problem. It’s generating a woocommerce general css file thats 132 kb large, which is absurdly large. The only setting I have enabled for it is async, nothing else. Please allow me to completely disable these files from being generated, they are taking up far too much space. And somehow, the cached file is bigger than the original. All caching options for css are entirely disabled.

    I have even tried deleting the asset cleanup cache directory entirely and every single thing is regenerated upon refresh. Please allow us to disable caching entirely, it should be the users choice whether they want it enabled or not. Let me decide whether it hurts or helps my performance.

    • This reply was modified 1 year, 5 months ago by jazir5.
    • This reply was modified 1 year, 5 months ago by jazir5.
    • This reply was modified 1 year, 5 months ago by jazir5.
    • This reply was modified 1 year, 5 months ago by jazir5.
Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Asset Cleanup with Autoptimize’ is closed to new replies.