Support » Plugin: Asset CleanUp: Page Speed Booster » Asset Cleanup options showing on website

  • Hi
    This plugin looks great and I very much want to try it out but it causes an issue on my website.

    When I come out of test mode, save changes and go to my website all the Asset Cleanup options show up at the bottom of my webpages.

    Am I doing something wrong or is it maybe a conflict with other plugins I use?

    Best regards
    John

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Gabe Livan

    (@gabelivan)

    @john53 are you using Cloudflare caching the free version without any WordPress cookie rules? If yes, that could be the cause. The Asset CleanUp options are ONLY showing if you’re logged in and have admin privileges. They never show for the guest users (better to test in Incognito mode). In a next release, I will provide an option to bypass Cloudflare (or any other caching plugin) aggressive caching and hide those options. That’s ONLY the case if you’re managing the CSS/JS in the front-end. Perhaps you’ll want to manage them within the Dashboard?

    Some print screens would be helpful if you can attach here so myself and everyone else would clearly see what’s going on there. I stand by this plugin 100% and always will, so something like that will always be fixable 😉

    Hi
    Sorry for the late reply.

    Thank you for the explanation.

    I am using your free version as well as wp rocket and cloudflare.

    I have page rules set in cloudflare
    1/ always use https
    2/ cache everything, always online, browser cache ttl – a day, edge cache ttl – a month.
    3/ bypass cache on login page

    I have changed my theme from customizr pro to astra, which is a lighter weight theme and runs faster.

    I have just tried your plugin again today and I am no longer getting the problem. I don’t know if that’s due to the theme or not.

    So I will experiment with your plugin to try to improve my mobile speed, to try and keep google happy.

    Thank you very much for producing such a brilliant plugin.

    Best regards
    JOhn

    Plugin Author Gabe Livan

    (@gabelivan)

    @john53 based on the information you provided, the problem is obviously from the “cache everything” feature. Even WP Rocket mentioned about it here: https://docs.wp-rocket.me/article/313-user-cache (scroll to “Cloudflare: Cache Everything”).

    First time when I noticed this problem was when the top admin bar was showing up in Incognito mode as well where I wasn’t logged in. Their free service is great, I use it as well, though options such as “Bypass Cache on Cookie” are available starting from the Business plan (it used to be Enterprise), check out this article here: https://blog.cloudflare.com/caching-anonymous-page-views/ – (see the “wp” and “wordpress” mentioned on their print screen from “Caching HTML”).

    Make sure the “/wp-admin/” area is never cached (there are ways around that, you can disable the caching completely for that area which is strongly recommended).

    For those who are using Cloudflare free service or other aggressive caching options, please use the Dashboard option for now (until an effective solution will be found) to manage the assets. Keeping it on will also cause random top admin bar showing up as well as content intended for the admin users only.

    Hope it helps, @john53 – if you’re happy with the plugin, perhaps you can leave a review here https://wordpress.org/support/plugin/wp-asset-clean-up/reviews/?filter=5 at your earliest convenience? That would be helpful!

    PS: Once I’ll update the plugin with a way to avoid the aggressive caching (e.g. through using special query strings in the URL), I’ll post the update on this support topic!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.