WordPress.org

Support

Support » Plugins and Hacks » AskApache Password Protect Plugin

AskApache Password Protect Plugin

  • Do we need to add the AskApache Password Protect (APP) plugin in WP v2.5.1? Or is it embedded in v2.5.1 already?

    It sounds as though AskApache Password Protect (APP) creates .htaccess and .htpasswd files & that only APP creates these files. Since I have these files in v2.5.1 and already have to log in to my site’s wp-admin section in a manner that sounds APP-ish, then surely I don’t need to activate this Plugin, … or do I?

    I have the AskApache Password Protect (APP) in my plugins section, but can’t remember if it came with the core plugins or I downloaded it thinking I needed it.

    What happens if we activate this plugin in v2.5.1 on top of already having APP? Is this why people are getting blank admin screens and error messages?

Viewing 2 replies - 1 through 2 (of 2 total)
  • APP only creates /.htpasswda1 (you choose where to create this file) and /wp-admin/.htaccess (which is only used when you turn on password protection.)

    WordPress creates the /.htaccess file when your server is capable and you use pretty-permalinks. APP just adds to this file.

    People are getting error messages and such because I’m still learning how to code robust for all servers and hosting providers that allow wordpress but .htaccess is something very different.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘AskApache Password Protect Plugin’ is closed to new replies.