Support » Plugins » Ask Apache Password Protect

  • Hello,

    First let me say Ask Apache Password Protect (AA Pass Pro) is useful (understatement) and works well. However, I upgraded to the exciting-looking version 4.5 and several tests show a red square.

    Two (perhaps obvious) questions:

    1. Does a red square mean the test failed?
    2. Are all red squares show-stoppers?

    Before I describe the tests I should point out that I’ve installed WordPress in a subdirectory but its index.php is in the site’s root directory. AA Pass Pro 4.5 creates a wp_admin directory in the site’s root directory — maybe because its confused about the installation. The WordPress Settings page knows what’s going on.

    The first failure confused me. It showed the same .htaccess path twice and said the first instance failed and the second instance passed — like this:

    • red /wp-admin/.htaccess file writable
    • green /wp-admin/.htaccess file writable

    I also got the ‘major bummer’ error: mod_auth_digest. Do I need to try to get hostmonster to enable that module?

    I also got errors on:

    • Basic Authentication Attempt using Crypt Encryption
    • Basic Authentication Attempt using MD5 Encryption
    • Basic Authentication Attempt using SHA1 Encryption

    Are they show stoppers?

    I also got some yellow squares…

    Finally, AA Pass Pro advises me to set AA_PP_DEBUG to true to see more information. A quick glance at the code revealed that AA Pass Pro already sets AA_PP_DEBUG to 1 but I don’t seem to get any useful diagnostic information — just some array listings that don’t make much sense to me.

    Thanks and all the best,


Viewing 8 replies - 1 through 8 (of 8 total)
  • Wellll, I just tried to upgrade my AskApache at work, always a bad idea, but I think of that too late. Once I install AA, I always put the file permissions back, so when I upgrade at work (I can’t access my control panel from here) I break my admin as I did now (joy!). I also only saw the initial checks (almost all red) and that definately means a ‘no go’ until you fix the things. Actually, the test page tells you exactly what is good and not so good. Unfortunately the plugin changed few things before running the test, so I’ll have to wait for after work hours to fix things. Hmm…
    There seem to be plenty of new features, so I can’t fill you in on all the details.

    Okay, I removed my 4.3.2 version and tried to install 4.5.1. I get the test results, have no idea what they mean or how to fix them, so I can’t make the plugin settings. I put back 4.3.2 and no problems. Some more documentation could be helpfull or clearer test results.


    AA Pass Pro 2.6 creates a wp_content folder in my site’s root directory. I think my site setup is confusing AA Pass Pro. WordPress is in a subdirectory called ‘main’ but the WordPress index.php is in the site’s root directory.

    Re mod_auth_digest my host, Hostmonster has stated that they will never enable mod_auth_digest. I explained the issue and escalated it it higher and higher support levels. Also, I’ve seen some recommendations elsewhere to leave the mod_auth_digest disabled.

    Ask Apache: is the fact that mod_auth_digest is disabled prevent AA Pass Pro from continuing?

    Man, I’d really like to get this going. I feel naked without it. Is anyone successfully using the new AA Pass Pro on shared hosting?




    I was able to make one minor change to the code and get past the initial check and then do all the protection except password protecting wp_admin. In my case a problem arose because I install wordpress in a ‘main’ subdirectory but put its index.php in root and set these values in settings

    WordPress address (URL)
    Blog address (URL)

    To support that setup I changed line 1547 (give or take) from:

    $home_path = rtrim( get_home_path(), ‘/’ ) . ‘/’;


    $home_path = rtrim( get_home_path(), ‘/’ ) . $path;

    That adds ‘/main/’ to $home_path and fixes it just enough to get me some basic protection.

    Hope that helps somebody,


    Sorry, the line number is 1836 – don’t change the one at 1363 (it may need changed but I couldn’t see an easy way to do it).

    Also, I had to deactivate then reactivate AA Pass Pro after I made the change. I think.



    Dude you rock! I was trying to figure out what could be causing this problem for a small minority of users, and you nailed it, I’ve fixed it for 2.7


    Im having this issue with my wordpress
    when in admin, trying to go in permlink section, i get this
    Fatal error: Call to undefined function get_home_path() in /home/okapixel/public_html/wp-admin/options-permalink.php on line 58

    any help would be great, also this page seems to load very slow when you visit the first time and i guess when its in your browser cache, its faster the second time, how come it loads so slow, is it from the hosting or from the error above?



    Thank you for this plugin. It works great once it works 🙂

    I want to let you know that the issue described by steinitz, being that wordpress is installed in a sub directory, persists in release 4.6.5 of your plugin. The code is looking for one of the .htaccess files in /htdocs/ rather than /htdocs/wordpress/.

    I modified your code in line 1545 by stripping the last slash appending $path instead.

    $home_path = rtrim( get_home_path(), ‘/’ ) . $path;

    Keep up the good work!


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Ask Apache Password Protect’ is closed to new replies.