Support » Theme: Ascend » Ascende slug, redirect portfolio page to portfolio no margins page

  • Hello,

    I helped with setting up a Free Ascend Theme. Propblem that still persist, is that the website “home” open a page grid with images, but with the wrong images. It should open the portfolio page ( that has the slug “projects”). And this problem have stayed this way since june/july this year.

    After I set up the wordpress database, self hosted, and installing Kadence Ascend Theme (Free), this problem prevails. And when I asked the one who owns the site on how the Full Grid page was set up, I learned that one had used one of your (Kadence) Portfolio pages that comes with the theme by default, with stationary images you set up as example pages. And replaced with their own images. So your example page “portfolio” was used.

    UNWANTED REDIRECT

    As much as I have figured out now, it seems the Kadence ascend portfolio page is redirected to a page called “Portfolio-no-margins”. Which of course show the wrong grid and not eeven the same amount of images (thumbs/Default images from the projects portfolio pages in Dashboard, in contrast to a regular page called portfolio)

    HOW TO SOLVE?

    Any ideas how I can get the portfolio page to open the slug “projects”? For the record, there is none, and never have been any page as far as I can see, called projects. Because “Portfolio” page with the slug “projects” is supposed to open a page called projects, with the thumbs/preview images for each Portfolio page.

    IS IT TWO PROBLEMS OR MORE?

    So, as far as I can see, its two or three pages confusing the he.. of me: “Home opens a grid with 8 images. And the Slug “projects” (Portfolio?) opens 14 images. Confusing, because “Portfolio” page in Pages has the slug projects. But when I write domain.se/portfolio, it doesnt open the “projects” page (portfolio page with the slug projects). Instead it is redirected to domain.se/portfolio-no-margins”.

    I feel I´m a bit of the end to solve this at this time. I need to know how think, trouble shoot.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • And, sorry for a long post and some bad grammar. / Stefan

    Hey,
    In your appearance > theme options > portfolio settings. Scroll down to the option “Select Default Portfolio Page” and there set the page you want to be the portfolio page.

    Let me know if that solves for you.

    Ben

    Hi Ben,

    Appreciate the help.

    Unfortunately it didnt help. And this is because I can not choose the slug link “projects. Which in this case reads http://www.yourdomain.com/projects . When I choose http://www.yourdomain.com/portfolio it is automatically redirected to http://www.yourdomain.com/portfolio-no-margin

    The annoying thing is that in the WP dashbord/pages the page Portfolio is being used. Its slug in the WP page sidebar (Gutenberg) permalink the slug link is http://www.yourdomain.com/projects.

    So, I dont know how to get around this.

    I would like to use Portfolio page in the WP Dashboard. So how can I make it not get redirected to portfolio-no-margin ?

    Stefan

    I guess I am not understanding.

    Where do you have a link to http://www.yourdomain.com/portfolio ? because the reason it would redirect from there to http://www.yourdomain.com/portfolio-no-margin is because there is an actual page on your site set up with the slug portfolio-no-margin. You can remove that page from your admin by going to pages. It is page id 6489

    Ben

    theillustrator

    (@theillustrator)

    Hi Ben,
    For some reason “Home” is always opening the wrong Portfolio page. Originally my partners website was created, using Kadence own Ascend Portfolio page called “Portfolio” in the Dashbord Pages. And simply replacing Kadence own photos, with her own images linked to her Portfolio (project) pages. And that one, in the Menu – “Portfolio”. But somehow Kadence/Wordpress aujtomatically renamed it to yourdomain.com/projects instead of portfolio.

    Go to http://www.canvas.nu/temp to click the links to my partners website . Its all there.

    Problem that also occurs is, this: I have created a completely NEW page in the Dashboard Pages called “Portfolio 1”. And created a new gallery using Kadence Blocks Advanced Gallery feature. But the “Home” still wont acknowledge the new page to be opened. And still open the wrong page. No matter what I do.

    I have een to that Theme Options have “Portfolio 1 selected. And the same with WP Dashboard/Settings/Read start /Home page: “Portfolio !”.

    Its really annoying.

    theillustrator

    (@theillustrator)

    I recorded a short youtube video for you to look at http://www.canvas.nu/temp where I go through the steps and so forth

    hannah

    (@hannahritner)

    Hey @theillustrator,
    Thanks for the video! I hope I’m following correctly. I think you just need to enable Page Content in your Homepage Layout Manager from Theme Options > Home Page Layout. Let me know if that corrects this.

    Hannah

    theillustrator

    (@theillustrator)

    Hi Hannah, You and Ben are the best. Big thanks! That did it!

    Glad you saw the video. Videos are often the best to show whats going on.

    Stefan
    ww.stefanlindblad.com

    hannah

    (@hannahritner)

    Oh good! Glad that worked. The video was very helpful:)
    Cheers!

    Hannah

    Hello again,

    It all work better now. Correct page opens up. But something seems to be causing the portfolio page showing double image/thumb twice. That is a double of each pic. I wonder if this may have to do with having an older portfolio page. I disabled one of them. I set it to private. But the new POrtfolio page that is the correct one still have what seems to be an extra horizontal set of squached empty thumbs area. SOmetimes I see the thumbs ok, but then it still show a column 3 layout on top. And a column 4 layout underneath. On the same page.

    I made a quick video showing the issue. Free Ascend theme Version: 1.4.3

    Have a loook here http://www.canvas.nu/temp

    hannah

    (@hannahritner)

    Hey,
    Apologies for the delay. It looks like you’ve added a gallery into your page. When you edit your home page (your portfolio page), do you see the gallery in the block editor?

    Hannah

    You can also go to theme options > home layout and move “page content” to disabled which will hide any blocks (like that gallery block) you have added to your page content.

    A quick note about the row of images that were only showing partials, it means you have set thumbnails image sizes incorrectly in the gallery block. Make sure when you choose a thumbnail image size in the settings that all your images are at least that size. For example if you choose large, make sure you have images that are all at least the large size.

    Thank you Hannah and Ben,

    Appreciate this. I will go through those steps tomorrow.

    Addiotnally I saw that the same thumbs dont all open when clicking on them. They are suposed to go to each of their portfolio (project) page. But I cant seem to get tat to work either. Havent seen any troubleshooting support on that. Any ideas?

    I was thinking that Hannah´s idea earlier today. Will let you know how it goes!

    Have a nice eveing

    Oh, reminded me there. Hannah helped me getting the galle page content to show up earlier. So I wont dare turn that off in theme options.

    If you create a gallery instead of using the portfolio posts output you will have to manually assign links to each gallery image in your gallery.

    Ben

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.