Support » Plugin: Media File Renamer - Auto & Manual Rename » articles images links not work

  • Resolved morpheuss

    (@morpheuss)


    Hello
    i’m making a test post with a picture.

    test.jpg
    then I renamed the images title to
    testpost.jpg

    After that the image is not rewritten in the article to testpost.jpg .
    So the picture is in the post knows da link is no longer correct.

    how can i fix??

    thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jordy Meow

    (@tigroumeow)

    Hi @morpheuss,

    Are you using a pagebuilder? If yes, which one?

    Thread Starter morpheuss

    (@morpheuss)

    Hello
    i only pagebuilder for pages not post.

    in post only the Classic Editor
    THEMECO Pro, Cornerstone pagebuilder

    Plugin Author Jordy Meow

    (@tigroumeow)

    I am sorry, but depending on the pagebuilder, you will need to update the references manually. I absolutely need to make a list one day (or somebody else should haha).

    Basically, good pagebuilders reference Media entries by their ID. So any changes in those entries (filename, ALT text, title, etc) will be reflected as they changed.

    Pagebuilders which are not well-developed use that information directly and only one time. Then, every update in the metadata is ignored (and the change of filename as well, of course).

    Thread Starter morpheuss

    (@morpheuss)

    But if I use the Classic Editor it must work??

    Thread Starter morpheuss

    (@morpheuss)

    Hello i repost your comment in https://theme.co/forum/t/images-referenced-in-x-pro-conerstone/77264
    the answer ist

    christian
    Staff
    17h

    Hey @ibuxxi,

    Regretfully, we currently use the URL of the image in the builder. I believe our development team has a good reason for using that most probably for performance purposes. But, I’ll post this in our issue tracker so they’d be aware of the Jordy Meow’s comment.

    For now, you need to do a Search and Replace. Search the old URL of your image and Replace it with the updated one.

    Hope that helps and thank you for understanding.

    Plugin Author Jordy Meow

    (@tigroumeow)

    In the Classic Editor, yes, it should totally work 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘articles images links not work’ is closed to new replies.