Support » Installing WordPress » array_keys, invalid argument, cannot modify header info problems

  • I have just uploaded WP2.5 to a new directory using an old database. The db was upgraded, but when I go to any page in wp-admin or my main site, I get:

    Warning: array_keys(): The first argument should be an array in /home/www/stuff/yearxi/wp-includes/widgets.php on line 654

    Warning: Invalid argument supplied for foreach() in /home/www/stuff/yearxi/wp-includes/widgets.php on line 654

    Warning: Cannot modify header information – headers already sent by (output started at /home/www/stuff/yearxi/wp-includes/widgets.php:654) in /home/www/stuff/yearxi/wp-includes/pluggable.php on line 689

    My server is on php 4.3.4 which is supposed to meet minimum requirements for WP.

    Any theories as to why this is happening?

Viewing 6 replies - 1 through 6 (of 6 total)
  • No takers? It’s been over a day now.

    Good thing I tested WP2.5 on a backup server and not my live site. I’d hate to be stuck with these errors all this time.

    Sorry to bump a thread like this, but I’m not sure how else to get help. I already searched this forum, but no one else has posted about this specific problem and since I had this problem on both an upgrade and a clean re-install, I don’t think this is my mistake.

    OK, in case someone else has this trouble, it seems to be something with my database and not my server. I deleted the tables on my back up db and then tried accessing WP2.5. It installed fine. However, once I imported the db again, it threw the exact same errors.

    From here it looks like some 2.3 dbs are not compatible with 2.5.

    Any advice would be very welcome.

    I got the same errors. I have a fairly fresh install of 2.5. No upgrading involved. I did export from and import into it.

    But, I encountered the problem when I was fiddling around with widgets. I widgetized my theme, so that could be it. But it was working fine for several days before I got the errors.

    I think I’ve tied the error to deleting a text widget. I think the error that it’s talking about having to do with foreach and array_keys surrounds the text widgets.

    I re-added a text widget…and the error messages disappeared.

    I don’t need help, but it seems that lots of people have had a similar problem so I thought this might help track down the source of the issue. (I HOPE I don’t need any help.)

    I can’t even get to the admin pages to show up. I did a clean install and Wp 2.5 seemed to work–when I imported the db from my other server I got the errors again. This is very frustrating since I’m not doing anything special here.

    I’m at the same place you are, with the same PHP files involved. I tried uninstalling all of my plug-ins to no avail. I suspect the database too, but I was using WP 2.5 and am bringing in a database from that set up.

    I’m going to try what you did and delete the tables and see what happens. I’m fearing a compatibility issue too and having to rebuild my blog. Add me to the list of any advice would be appreciated at this point.

    If anyone managed to solve this problem, we would love some advice. We are having the same problem. We don’t mind having to rebuild the blog, as long as we know what is safe to put back into the new WP to get back the posts & comments without starting the errors again.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘array_keys, invalid argument, cannot modify header info problems’ is closed to new replies.