Support » Plugin: WP-Optimize - Clean, Compress, Cache. » array_key_exists() expects parameter 2 to be array in wp-optimize.php on line993

  • Resolved dandelion89

    (@dandelion89)


    Hi,after the last update we have such an error on most pages of the site and the admin panel.
    Warning: array_key_exists() expects parameter 2 to be array, boolean given in **********/wp-content/plugins/wp-optimize/wp-optimize.php on line 993

    Warning: Cannot modify header information – headers already sent by (output started at **********/wp-content/plugins/wp-optimize/wp-optimize.php:993) in **********/wp-admin/includes/misc.php on line 1114

Viewing 3 replies - 1 through 3 (of 3 total)
  • Just upgraded and got the same error. Deleted plugin.

    Plugin Author David Anderson

    (@davidanderson)

    Hi,

    Please de-install, and re-install the plugin, and the PHP notice will be gone. Your settings will remain.

    It’s best not to configure your web hosting to send PHP notices to the web browser; it’s much better to send them to a log file.

    David

    Thanks, David, it helped me.
    I turned off the error display on the site and enabled logging. But for some reason after all these actions I continued to see warnings in the admin panel (dashboard) in the Site stats block.
    After reinstalling the plugin and cleaning the cache, the warnings disappeared.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘array_key_exists() expects parameter 2 to be array in wp-optimize.php on line993’ is closed to new replies.