Support » Plugin: Max Mega Menu » Arrange an order of menu items

  • Hi! Please believe me I spent hours trying to figure it out myself … before I thought about bothering you with this.

    I am using the free version of Max Mega Menu and I have 2 issues for which I could not find a solution:

    1. The order in which column items are displayed …
    I have one divided into 2 columns (as I saw you recommended in another similar answer) and the plugin tries to order them as it sees fit! hehehe
    I would like them to be shown ordered as

    1 4
    2 5
    3

    2. I find a (undesirable) space that remains between the items, with which the plugin seems to be trying to “justify” the vertical space of the menu … and I did not find either, a way to avoid it

    For now, I think you can see it in the link of the site that I have added to my post … but I leave you some screenshots, so that you can appreciate it in more detail what I’m talking about

    Menu items order at admin page
    Menu as it’s being shown

    I sincerely hope, you can give me a hand with this …
    I really thank you in advance!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author megamenu

    (@megamenu)

    Hi speedbit,

    Thanks for posting a link and screenshots.

    I think this would be easier to manage if you moved these sub-sub items up one level (so they are in line with Informatica and Electronicos). Then they will show up in the grid layout builder and you can drag and drop them into the correct place:

    2020-08-17_10-44-19

    You then may need some custom CSS to make the Informatica and Electronicos items look distinct from the other second level items.

    Regards,
    Tom

    Thread Starter speedbit

    (@speedbit)

    Hi Tom, I really thank you for your answer! Your workaround worked for me and although it is somewhat cumbersome, it absolutely does the job.

    There is another question I would like to ask you …
    How can I get the “Productos” menu to be expanded by default in the mobile version?
    (by tapping on the hamburger icon, I mean)

    Thanks in advance,

    Notice: the “Productos” item, it´s the only element that I’ve setted as active in the mobile menu. May be you want to consider this, if to expand the whole menu is an easier way to get it work… it will be enough for me! hehehe

    • This reply was modified 1 year, 9 months ago by speedbit.
    • This reply was modified 1 year, 9 months ago by speedbit.
    Plugin Author megamenu

    (@megamenu)

    Hi Speedbit,

    Can you set the mobile menu background to black (it is transparent at the moment), then uncheck the ‘Hide submenu on mobile’ option for the Products item? Then I will take another look.

    Regards,
    Tom

    Thread Starter speedbit

    (@speedbit)

    Hi Tom, Sorry for my late update…

    I made a mistake trying to figure out the mobile menu:
    I wanted to revert the changes made to the CSS and (half asleep), I reset the whole theme!
    Angry with myself, I left it as it was and it was not until now, I get back to work on the site! hehehe
    I’m going to finish redoing all the customizations that I already had done … and then I’ll go back to the mobile menu and work on your suggestion …
    Of course, I’ll tell you later how it worked!

    I sincerely, SINCERELY appreciate your attention.
    We are in touch! =)

    Thread Starter speedbit

    (@speedbit)

    Here Again!

    Unfortunately it didn’t work.

    I was able to change the background color of the mobile menu and I got “Productos” to be correctly displayed… but without submenu and in fact, it does not respond to the tap either (it does not display subordinate items).

    (Update: Of course, I’ve checked that they are not being “hidden” for mobile menu!)

    So, I tried -according to your suggestion- by checking the option to hide “Productos” in the mobile menu (which is actually, the only one I want to be shown and expanded) … and now, when you tap on the hamburger menu, it shows NOTHING! =(

    • This reply was modified 1 year, 9 months ago by speedbit.
    Thread Starter speedbit

    (@speedbit)

    Tom, I’m really really sorry!!… it was just (and absolutely) my mistake!

    I don’t know when/how/where/why I had activated the “hide submenu” option… within the “Products” options!

    Although some customization settings are still missing, everything is now going as I want it… just perfect!

    THANK YOU FOR YOUR PATIENCE AND GOOD WILL!
    =))

    Plugin Author megamenu

    (@megamenu)

    Hi speedbit,

    Glad to see you have it up and running again. The sub menu is looking better 🙂

    To reveal the Products sub menu on mobile by default, go to Mega Menu > Menu Themes > Custom Styling and add the following:

    @include mobile {
        #mega-menu-item-455 > ul.mega-sub-menu {
           display: block !important;
        }
    }

    Regards,
    Tom

    Thread Starter speedbit

    (@speedbit)

    Sorry to bother again…

    Is there a way to “hide” at de mobile version, the “Productos” title bar… while showing it´s sub-items expanded by default (as you suggest previously)??

    In a way that by tapping the hamburger icon, you can only see the “Productos” sub-items, but NOT the “Productos” title?

    Thanks again! =)

    Plugin Author megamenu

    (@megamenu)

    Hi speedbit,

    Not easily, sorry.

    Regards,
    Tom

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Arrange an order of menu items’ is closed to new replies.