Support » Theme: Arjuna X » Arjuna X breaks wordpress 3.5

  • Resolved mhomann

    (@mhomann)


    After upgrading to wordpress 3.5, the “add media” button does nothing if the arjuna x theme is active.

Viewing 15 replies - 1 through 15 (of 48 total)
  • the “add from the most used tags” link does not work either.

    Arjuna X has broken various features for me too:

    – Jetpack “Site Stats” no longer works in the dashboard and may not be logging my hits.

    – Hovering over the wp-admin menu items no longer brings up the sub-menu for each one – I now have to click on each menu on the left to get the sub-menus!

    I’ve just had a look at the author’s profile page (http://profiles.wordpress.org/sebastianrs/) and his last activity on this site was 489 days ago… I hope you find this conversation “sebastianrs” and can help to resolve it, otherwise we all have to find a new theme!

    Hi everybody! I think I’ve found the solution. Just delete file jquery-ui-1.8.10.custom.min.js from lib folder of Arjuna theme. It works for me. Hope it will help someone. Cheers!

    Any idea what “jquery-ui-1.8.10.custom.min.js” is actually there for?

    It may fix the problem, but then may cause others… 🙂

    Right… i’ve found it:

    Line 1910 of wp-content/themes/arjuna-x/functions.php:

    function arjuna_admin_initJS() {
            wp_enqueue_script('fionnFarbtasticJS', get_template_directory_uri() .'/lib/farbtastic/farbtastic.js');
            wp_enqueue_script('arjunaAdminJS', get_template_directory_uri() .'/admin/admin.js');
            wp_enqueue_script('arjunaJQueryMinJS', get_template_directory_uri() .'/lib/<strong>jquery-ui-1.8.10.custom.min.js</strong>');
    }

    The function arjuna_admin_initJS is then referenced here:

    //JS for plugin page
    add_action('admin_print_scripts', 'arjuna_admin_initJS');

    Does anyone know what this all does or whether it is safe and sensible to just delete jquery-ui-1.8.10.custom.min.js?

    Also, deleting this file hasn’t fixed any of the problem for me… how strange.

    Yep, it’s really strange, but there’s no free support from developers, so we can only hope for the better…

    P.S. Tested. Clean your cookies/cash after deleting.

    Unfortunately, clearing my cache, cookies, history, everything and even trying a brand new installed browser it doesn’t work.

    Regarding the developers, they have been good in the past with helping out, but I don’t know how often they read this forum…

    I’ve sent them a ticket through their own website, maybe that’ll wake someone. They are a professional webshop after all… and not bothering to fix a product reflects badly.

    Delete the jquery-ui-1.8.10.custom.min.js work for me just I not like it.

    I downloaded the 1.9.2 version here http://jqueryui.com/ , renamed with same name than the 1.8.10 version and replaced the old version by the new and this look work good just I’m not sure is a good idea?

    hmm still nothing happening here, and no answer to the ticket I’ve send them.

    same here… i’ve sent them a “Quote Request” through their web site, but then found their email address so sent them an email too. This was on the day day I replied to this thread.

    Still no reply! I’ve even tried phoning them, just to make them aware of the issue, but just got voicemail.

    I’ve found only one issue (tested on Win7 x 32 & OSX x 64 with Chrome, Opera. MZ, IE) – in the theme options link to WP site is around 30% up from footer in administration panel overlaying original buttons. But I can live with that anyway.

    how strange… i’m running the latest Arjuna X theme on WordPress 3.5 and have tested on:

    – IE8 on WinXp
    – IE8 on Win7
    – IE9 on Win7
    – Chrome on WinXP
    – Chrome on Win7
    – Chrome on Linux
    – Firefox 3 on Linux

    I have both my problems (hovering over menu links in wp-admin doesn’t bring up sub-menus & Jetpack Site Stats don’t show up in wp-admin) in all these browsers!

    How strange!

Viewing 15 replies - 1 through 15 (of 48 total)
  • The topic ‘Arjuna X breaks wordpress 3.5’ is closed to new replies.