Support » Plugin: WP-PageNavi » Argument #2 is not an array in … scb/Options.php on line 62

  • Resolved trgreen17

    (@trgreen17)



    Full error message: Warning: array_merge(): Argument #2 is not an array in wp-content/plugins/wp-pagenavi/scb/Options.php on line 62

    I’ve seen several variations of this in the support queue on different line numbers, with patches to fix it, but this seems to be much more recent.

    Oddly, it only happens when I push my local site up to Pantheon. Locally, in MAMP Pro, I never see this error and the pager works great.

    Any ideas or recommendations appreciated.

    https://wordpress.org/plugins/wp-pagenavi/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Lester Chan

    (@gamerz)

    Do you get this problem everytime? try going to WP-Admin -> Settings -> PageNavi and save the settings. I got a feeling it is because the settings are blank.

    Hi, and thanks for the quick reply!

    Yes, the settings are blank up at Pantheon, but they are filled in on my local so it works there. But when I uploaded the local database to Pantheon shouldn’t the settings have come with it?

    Additionally, I cannot add the settings while it is on Pantheon… when I put them in and hit “Save” the page reloads and says “Settings saved” but they are not. Also, at the top of the page is the following error:

    Warning: array_merge(): Argument #2 is not an array in /srv/bindings/7df8b2e0adcb4053941259330813af02/code/wp-content/plugins/wp-pagenavi/scb/Options.php on line 62 Warning: array_merge(): Argument #1 is not an array in /srv/bindings/7df8b2e0adcb4053941259330813af02/code/wp-content/plugins/wp-pagenavi/scb/Options.php on line 93 Warning: array_merge(): Argument #2 is not an array in /srv/bindings/7df8b2e0adcb4053941259330813af02/code/wp-content/plugins/wp-pagenavi/scb/Options.php on line 62 Warning: array_merge(): Argument #1 is not an array in /srv/bindings/7df8b2e0adcb4053941259330813af02/code/wp-content/plugins/wp-pagenavi/scb/Options.php on line 127

    Update: I tried disabling the plugin and re-enabling it and I am still unable to save the settings on Pantheon. Still working fine on my local MAMP Pro installation. Any help greatly appreciated.

    Update: Never mind… I figured it out. When I export the database from Sequel Pro and upload to Pantheon it messes up. When I export from UpDraft Plus it works fine.

    My bad, sorry to waste your time. Thanks for your help, marking as resolved.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Argument #2 is not an array in … scb/Options.php on line 62’ is closed to new replies.