Support » Plugin: MailChimp STS » Argh! Have done all setup but can't get plugin to work…

  • Resolved leebranch


    Hi there,

    I’m having trouble setting up the Mailchimp STS plugin.

    I have been through the setup instructions carefully:

    – I have installed the plugin
    – I have added my Mailchimp API from my PAID Mailchimp account
    – I have integrated Amazon SES with Mailchimp with the security keys etc and in the integrations section of my Mailchimp account have a green light, the word connected, and confirmation that I am in Amazon’s production environment with a 24 hour sending quota of 1,000 emails
    – I have verified the email address I am sending from via Amazon SES, and adding the email address to verify into the Mailchimp STS sends me another verification email from Amazon with a link, which I have clicked and been taken to an confirmation page saying the email is verified

    When I go back to the plugin page though it says “No verified email found.” by the email addresses label under Verified Addresses.

    When I click to send a test email message I get an error at the top of the page that says:

    “Test email send failed. Missing final ‘@domain'”

    I checked the email address carefully on the test message and it’s correct, and tried a few times but always get the same error message.

    It’s taken ages to get this far with the setup – in Mailchimp, in Amazon Web Services, in WordPress – and we’re trying to launch our site tomorrow. Could someone please offer some advice as soon as possible!

    Thanks so much for your help,

    Lee Branch

    PS: I have screengrabs of the integration panel working, and the congratulations you’ve verified your email page, but no way of attaching here as far as I can tell…

Viewing 8 replies - 1 through 8 (of 8 total)
  • To try and establish if the problem is with the email address verification I just used to check and the email address I want to send emails from via WordPress STS is definitely verified.

    It is also the same email address as the address in the General Settings tab in WordPress.

    Can anyone tell me why this address shows as verified using the other software but not on Mailchimp STS?

    Hello Lee,

    WordPress plugin retrieves information about verified addresses from STS API. Either plugin fails to accomplish that for some reason or your email is not being reported as verified by API.

    So let’s try to figure this out first. You can see list of verified emails, as returned by API, by opening such link:

    Use your MailChimp API key in the link and (if needed) change us1 at start of link to your datacenter (as reported by WP plugin and specified at end of your API key).

    Thanks so much for your help, this is above my pay grade so thanks for the simple instructions too!

    I’m on us2 so changed that, and added my API key (the same one given to the plugin) and it confirmed that the email address I’m trying to send from is verified.

    Message was:

    {“email_addresses”:[“CORRECT EMAIL ADDRESS”]}

    Have taken out the actual email address from above as don’t want to be spammed!

    What’s next?

    Thanks again,

    Ok. Plugin can report “No verified email found.” in two cases – there are no verified emails at all (which we excluded) or API request had failed for some reason.

    1. Do you get any other errors from plugin on settings page or report page (in Dashboard section of menu)?

    Especially messages starting with “API error.”. If API key is configured plugin silently performs API check every time you open its settings page and gives such error if check fails.

    2. Are you sure your WordPress installation is capable of performing outgoing network requests? Does things like checking for WP/plugin/theme updates and email notifications (with MailChimp STS plugin disabled) work?

    1. No errors on the report page, just a picture of the Mailchimp monkey at the top, and a graph showing zero sends for the last 14 days

    2. Not sure what you mean! We’re on the latest version of WordPress, all plugins are up to date, and I have upgraded plugins to newer versions (that I got a notice about releases being available on the plugins page) and installed new plugins too.

    It’s a heavily customised theme…aaahhh…perhaps that’s something to do with it?

    Basically the site allows users to create advertisements (posts) and at the end of the creation process they’re given a login.

    The details (username and password) are emailed to them – it’s these emails and a few others (listing has expired etc) that we want to send through this plugin.

    The email notifications (here are your details…your listing has expired…notice of new listing sent to the admin address…) all work fine with and without this plugin installed.

    Do you want to log in and have a look around?

    I am puzzled. From your description so far seems like everything but retrieving verified emails works. Send probably doesn’t work because it doesn’t have email address to use.

    Please drop me email in if you want me to have hands on look at your MailChimp and/or WP setup.

    This is one very obscure bug. Under some narrow conditions (I suspect that length of data is a factor) MailChimp API replies with HTTP response that cannot be correctly uncompressed by WordPress.

    Quick code fix that checks if response holds valid JSON data and tries to correct compression issue if not:

    add_filter('http_response', 'mailchimp_http_response_inflate_fix', 10, 3);
    function mailchimp_http_response_inflate_fix($response, $args, $url) {
    	if( false === strpos($url, '') )
    		return $response;
    	$json = json_decode($response['body']);
    	if( is_null($json) ) {
    		$inflate = @gzinflate(substr($response['body'], 2));
    		if( false !== $inflate )
    			$response['body'] = $inflate;
    	return $response;

    For the benefit of anyone else reading this with the same problem…

    Rarst also suggested by email that I verify a few more addresses as a longer response might help fix the problem (the problem of compressing and uncompressing part of the API).

    I did this, and it didn’t work straight away, but after clicking around the Admin and saving the setting a couple of times, it started working.

    ‘Tis a beautiful thing =)

    A big +1 to Rarst who was uber-helpful, thanks so much.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Argh! Have done all setup but can't get plugin to work…’ is closed to new replies.