Support » Fixing WordPress » Archives/About/Contact still not working! Professional help please!!!

  • Resolved Breno Nunes


    Hello guys!

    I don´t know what to do anymore, I´m using Chris Pearson´s Cutline theme and I have done the modifications he suggested in the first solution here ( but that didn´t work out and I can´t even try the second solution because I´m really not finding where is the ID number of the pages in 2.5 WP Panel. And now it´s even worse because when I´ve uploaded the .htaccess into my ftp even the categories stopped working. Obviously, that´s all my own fault but I can´t get it right without help. So if you guys have any idea of what´s going wrong in my blog, I please ask you to be a little bit more specific, all right? I´ll paste whatever code here that you may find necessary. Thanks a lot once again!

    My web address:

Viewing 12 replies - 1 through 12 (of 12 total)
  • I’m certainly no professional, but…

    I´m really not finding where is the ID number of the pages in 2.5 WP Panel.

    Go to Dashboard –> Manage –> Pages.

    In most browsers you can hold your cursor over a link and the URL to that link will appear at the bottom of the page. Hold your cursor over the title of your page (but don’t click).

    The link to that page (with the page ID as part of that link) should appear in the status bar of your browser. For example, you might see:

    … where “14” is the ID of the page.

    And here is a great page of instructions that might help you: “FAQ for 2.5.” It explains more about how to do stuff in WP version 2.5.

    As for the categories problem in with .htaccess, you might try to delete the .htaccess file via ftp and see if that fixes the problem.

    Can we assume that you were setting pretty permalinks, and that you didn’t append the new code into an .htaccess file that was already there? If that’s true, then you can either delete or rename .htaccess to see if that fixes it.

    Did you load your .htaccess fie in the directory where you have WordPress installed?

    Thanks a lot mechx1 and RosieMBanks! I found the ID, but the problem is that the .htaccess file is not appearing in the directory where I uploaded it (/public_html/blog/wp-content/themes/Cutline2pt1), and since today is holiday in Brazil I can´t find none of the hosting staff in msn or skype to ask for support… :/

    Anyways, here´s some info about how things are set on this moment for my blog, can you say by looking at it if I´ve done anything wrong in here?

    1 – In my WP Panel, the permalink set to “Quem Somos” (or ´About´ as you would like it…) is this:
    And that´s the same for the pages “Contato” and “Arquivos”.

    2 – And here´s how the coding is right now in the archive header.php:


    <ul id=”nav”>

  • href=”<?php bloginfo(‘url’); ?>”>Principal
  • href=”<?php bloginfo(‘url’); ?>/?page_id=15/”>arquivos
  • href=”<?php bloginfo(‘url’); ?>/?page_id=13/”>Quem Somos
  • href=”<?php bloginfo(‘url’); ?>/?page_id=14/”>Contato
  • <li class=”rss”>“>RSS

    Thanks a lot once again!

I could be totally steering you the wrong way here, but I seem to remember a webhost set up so users like me could NOT see the .htaccess files after we uploaded them. We could upload .htaccess files, but they seemed to disappear after we uploaded them.

Perhaps you could try this first: create a new .htaccess file but leave it blank, and upload it into the same directory.

My reasoning: before you uploaded that .htaccess file, everything worked except for the header navigation, right? So let’s fix the .htaccess problem first.

When I try:

… I get an empty page. You can see everything with no error message.

When I try

I get redirected to Arquivos, which throws a 404 error.

(I’m guessing you deleted page id #2, so there’s nothing in the database to redirect.) Your redirects aren’t working, and I think that .htaccess is to blame.

Again, I’m no expert!

Well, Rosie, I´ve certainly given that a shot! Unfortunately it didn´t work out either… I don´t know, maybe the .htaccess file already existed in my ftp and its update wrecked the code. Then again, I´m not sure about a damn thing on this subject. What WP Panel requested me to update was this:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /blog/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /blog/index.php [L]

I got no idea really! I´ve already undone even that modifications I did in header.php, that went back to (example):

  • about
  • instead of (example):

  • about
  • But nothing again…

    It seems that the categories and post pages are back to work! I just changed the option of the permalink on WP Panel back to “default” and that did the trick. But as for the navigation menu, nope… And I´d really like to have the pretty permalinks working instead of those crap links. I´ll spend my night trying to figure out that…

    Well, now everything is working, just with “ugly links”, but at least it´s working. Thanks a lot!

    It seems that the categories and post pages are back to work!

    That’s good news! But why do you still have the same redirect problem for that dang navigation bar? Arrgh!

    Even though you’ve made good progress in fixing this problem, I’m really struggling for an answer here because I don’t know enough about this topic.

    My gut feeling is that there’s an .htaccess floating around in your directory somewhere that needs to be deleted or overwritten, but if you’ve already done that, I don’t know what else to suggest. Hopefully somebody more familiar with permalinks will step in and offer assistance.

    At the very least, once you get those webhost guys back from holiday you can ask them to look into it. It might be some setting they need to adjust.

    Rosie, my navigation bar is now working, but I had to establish ugly links to the whole blog. Maybe when I got more familiarized with CSS coding I´ll take another chance on setting the pretty ones once again… Thanks so much for all the help!

    Breno, have you seen this thread?

    They found a bug in the 2.5 permalink structure, which was fixed here:

    You can download the rewrite.php file and upload it into your wp-includes folder. It might fix your problem!

    Thanks Rosie! Maybe now I can use the pretty permalinks… Let´s see… See you!

    Rosie, it worked just great!!! Thanks very very much! ;P

    Viewing 12 replies - 1 through 12 (of 12 total)
    • The topic ‘Archives/About/Contact still not working! Professional help please!!!’ is closed to new replies.