WordPress.org

Ready to get started?Download WordPress

Forums

Archives question (4 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    I have my .htaccess file in my blog/ folder, it goes like this:
    RewriteEngine On
    RewriteRule ^archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /blog/wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^archives/category/?(.*) /blog/index.php?category_name=$1 [QSA]
    RewriteRule ^archives/author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /blog/wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^archives/author/?(.*) /blog/index.php?author_name=$1 [QSA]
    RewriteRule ^archives/([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([0-9]+)?-([_0-9a-z-]+)?/?([0-9]+)?/?$ /blog/index.php?year=$1&monthnum=$2&day=$3&p=$4&name=$5&page=$6 [QSA]
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([0-9]+)?-([_0-9a-z-]+)/(feed|rdf|rss|rss2|atom)/?$ /blog/wp-feed.php?year=$1&monthnum=$2&day=$3&p=$4&name=$5&feed=$6 [QSA]
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([0-9]+)?-([_0-9a-z-]+)/trackback/?$ /blog/wp-trackback.php?year=$1&monthnum=$2&day=$3&p=$4&name=$5 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /blog/wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /blog/wp-feed.php?feed=$1&withcomments=1 [QSA]
    I have this on my httpd.conf
    <Directory /var/www/blog/>
    Options FollowSymLinks
    AllowOverride AuthConfig FileInfo
    </Directory>
    All rewrite rules work, feeds, comment feeds, archives by category, author etc, except archives by year/month. I cant seem to figure this out, any ideas?
    http://m4rccd.homelinux.net see the bottom right of the menu theres link to archives, none of them works though.

  2. Beel
    Member
    Posted 10 years ago #

    you have post id and name in your permalink?

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    My permalink is
    /archives/%year%/%monthnum%/%day%/%post_id%-%postname%/
    So yeah.. but why does that matter?

  4. Anonymous
    Unregistered
    Posted 10 years ago #

    Changing /archives/%year%/%monthnum%/%day%/%post_id%-%postname%/
    with
    /archives/%year%/%monthnum%/%day%/%post_id%/%postname%/
    did the trick, thanks man!
    btw: I think this is a known bug in wp 1.2

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.