Support » Plugin: Custom Post Type Date Archives » Archives pages are all blank

  • I installed this plugin so I can have archives for my CPT. It seems to work great till I try to click a date on the calendar widget or open a specific archive month, it just show a completely blank page.

    – I made sure that my CPT had the “Has Archive” and “Hierarchical” set to “true” in my CPT settings when creating it.

    – I also made sure that the checkbox “Add date archives” was checked for my new CPT in the “Date Archives” section

    – I checked the example URL in the Help section of “Date Archives” and it seems fine… I even try to do “Daily” instead of “Monthly” for the Archives widgets but still blank

    – I even tried to add snippets that add your CPT to your regular blog feed but still no changes

    I saw in the plugin description it said:
    “WordPress doesn’t support date archives for custom post types out of the box. This plugin adds the rewrite rules needed to view the date archives at a pretty permalink.”

    But I am not sure this is actually working (for me only maybe)? It only works for regular posts!

    Any chance you may know to make it work? Is there something to do about this permalink structure?

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author keesiemeijer

    (@keesiemeijer)

    Hi farou777

    Try re-saving your permalink structure at wp-admin > Settings > Permalinks.

    If that didn’t work try it with all other plugins de-activated.

    Thx for your quick reply! I forgot to mention but re-saving my permalink structure was the first thing I tried. Problem still persist and all custom post archives page are all blank! I just try to de-activate ALL plugins (only CPT UI and Custom Post Type Date Archives are activated) still blank!!! I am surprise nobody experienced that? I need to find a fix 🙁

    Any idea on a solution here? I have been searching a lot yesterday and today and cannot find why I can’t get the archives to show my CPT 🙁
    Thx

    Plugin Author keesiemeijer

    (@keesiemeijer)

    Could you also try it with the default theme 2019.

    I see also if you go to the post type archive /auctions you get redirected to a page /auctions-2.

    Do you have a Page called auctions (or in the thrash)? I think that could be the cause of it.

    Plugin Author keesiemeijer

    (@keesiemeijer)

    Never mind, this plugin thinks the custom post type archive is at /auction non /auctions

    Can you show me the code how the post type is registered? If that’s possible with CPT UI.

    Plugin Author keesiemeijer

    (@keesiemeijer)

    Also set WP_DEBUG to true in your wp-config.php file. Maybe some errors will be displayed.

    Debugging in WordPress

    Hello thx for your answer, I just tried to create a new post type called “movies” and the problem is the same! I am not sure what code you want? I called my CPT just “auction” with “auctions” for plural. Didn’t set a custom slug.

    Plugin Author keesiemeijer

    (@keesiemeijer)

    I’ve not checked out CPT UI plugin, so maybe they have an option to export the code to register the post type yourself.

    Try using the default theme Twenty Nineteen (for testing)

    Hi,

    Just wanted to provide my support…

    The reason the archives pages are blank is because the theme you are using doesn’t have an archive.php file and the plugin doesn’t fall back to the index.php. I will open a new forum post to see if the plugin author will push out an update.

    – AJ

    Plugin Author keesiemeijer

    (@keesiemeijer)

    Thanks WPExplorer

    That’s indeed the reason it doesn’t work. I will update the plugin with the fix for this issue in the following days.

    Thanks again

    Plugin Author keesiemeijer

    (@keesiemeijer)

    @farou777

    If you still want to try, the development version of this plugin has this issue fixed.

    You can get it here
    https://downloads.wordpress.org/plugin/custom-post-type-date-archives.zip

    I will update the plugin after some more testing

    @keesiemeijer hello!

    This is great I can see my custom posts when I click an archive link (example: “2018”) so thank you 🙂

    BUT of course I run into another little issue.. If I click and archive link for my regular posts, the page title says for example “Yearly Archives: 2019” and this is good, whereas if i click an archive link for my CPT, the page title just show the CPT slug I think. Same for the breadcrumbs, I can see the full path for regular posts:

    Home » Blog » 2019 » Monthly Archives: July 2019

    But for my CPT, the path is not generated, it just says:

    Home » my-CPT-name

    How can I make the CPT archives page titles and breadcrumbs do the same thing as my regular posts? So users know what they are browsing. Is this something that is wrong with your plugin or it comes from elsewhere?

    Thank you.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.