WordPress.org

Ready to get started?Download WordPress

Forums

Magazine Basic
[resolved] Archives not working...? (5 posts)

  1. Bart56
    Member
    Posted 1 year ago #

    The archives widget appears on my 3rd column on right. When you click it, it goes to /home/2013/05/ and displays the directory listing. How can I fix this?
    Yes this is my first WordPress install, but I've searched the support forums and there are plenty of thigs to do for archives, but this should work without modification - right?

  2. c.bavota
    Member
    Theme Author

    Posted 1 year ago #

    Make sure your permalinks are set up correctly. Go to Settings => Permalinks in the admin.

  3. Bart56
    Member
    Posted 1 year ago #

    Thanks for the response. I changed the permalink to /domain.com/?p=nnn (the first option and it works, but I was hoping to use the year/month directory format. I probably am doing something wrong, but the default setting seems to work.
    Is there a reason that the other permalink format doesn't work?

    - Bart

  4. c.bavota
    Member
    Theme Author

    Posted 1 year ago #

    You might have to manually add the necessary code to your .htaccess file. Read about that in the codex http://codex.wordpress.org/Using_Permalinks

  5. Bart56
    Member
    Posted 1 year ago #

    I added the recommended to the .htaccess file

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    It will take me some time to figure all this out, but the site still works :-)
    Thanks for the help.

    Bart

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic