Support » How-To and Troubleshooting » [Resolved] Archives – how to disable or remove?

[Resolved] Archives – how to disable or remove?

  • Howdy,

    My website posts are not date-based. Actually, I have replaced date stamps with category images. The only thing that needs improvement are the archives.

    I understand that they are not duplicating content, but they ARE getting indexed by bots. I have installed Platinum SEO plugin but it didn’t fix it. I have doublechecked all possible options through the dashboard, that refer to archives.

    Robots.txt is taken over by the XML-sitemap plugin, but I have added:
    Disallow: /archive/
    Disallow: /2008/
    Disallow: /2009/
    And still archives are being followed and indexed.

    Is there a way to just disable archives totally?
    First, I don’t need them at all since my website shows all the posts in the sidebar (through neat and expendable tree). Second, I don’t want them to get indexed and followed.

    Thanks for help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • C’mon, lads… I searched the forums but didn’t find the right solution.

    Hey guy,

    If your archives are displayed using an archive widget, you could remove the widget from your theme’s sidebar using the backend…

    Or, if you’re not using a widget, you could delete all the archive related code in the various template files…

    Which theme are you using?

    A more hardcore solution would be to use .htaccess directives to manage all calls to /archive/ (in addition to removing the template calls!)

    Here is my website:

    I just deleted archiving calls from the sidebar (it looked dead though) and deleted archive.php file. All calls to /2008 ect. are redirected to the index page. The title still says ex. 2008 September


    The only 2 widgets I have is dTree and Minimeta.
    I am using heavily redesigned CopperRocker.

    I am playing with redirection plugin a bit.

    I managed to redirect year/month/day (has to be a complete string) archives to a random post using regex. Can’t get to make it work with /year/… (with just /year or /year/month or /year/month/day) expression.

    Hmmm, I’m a little groggy so apologies if this suggestion is off-track: please get a second opinion: permalinks.

    This article discusses something similar, especially since you’ve essentially changed the way your site will be indexed…

    There are plugins mentioned too


    oh: http://codex.wordpress.org/Using_Permalinks

    I should thank you for doing the Lord’s work with the BritComs. Ta!

    Thanks for the kind words about my website. It’s still pretty new but getting some hits here and there. Hopefully it will get more popular since so many of us love British humor 😛

    Regarding the problem. I just got crawled, http://www.britcomvideos.com/2008/09/page/93

    This was without redirection plugin on. Platinum SEO has all archives set to noindex. XML sitemap has archives untagged.

    I just added /2008/ to rejected URI’s at WP supercache plugin. Wonder if that’s gonna change anything.

    I will look into links You gave me. I guess it will take more time than I originally thought to get that fixed.

    Just wish there was a way to stop creating archives at all.
    BTW, I already deleted archives.php and it didn’t do much besides not displaying it’s template.

    I just tried robots-meta plugin and it looks like archives can’t be accessed directly. http://wordpress.org/extend/plugins/robots-meta/

    If archives are not going to be crawled anymore, problem solved. Let’s see what happens.

    Ok good,

    BTW, the archives.php simply formatted data that was in your db already, so you’re correct that the same data is being collected (post date etc).

    It’s going to be collected anyway as part of the core functionality but you do get to choose/manage how it’s displayed/made available. You should check your RSS feeds to as more and more content is pulled that way.

    I think the permalinks update followed by recreating your sitemap for google etc will go a long way…

    Since archives haven’t been crawled for few days now, I can safely call it solved.

    To sum it up,
    – archive.php was deleted so no entries would be displayed in archive format
    – all archive calls have been deleted (in my case, ones from sidebar.php)
    – robots-meta plugin did the trick rewriting archive addresses to homepage

    I don’t exclude possible fix by using permalinks as suggested above but these 3 steps I mentioned did it.

    I am archive-free!

    Now, to battle RSS formating. It’s ugly with video content 🙁

    it is more than stupid to delete archive.php file. so nobody can see whole category, or post by tags…

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Archives – how to disable or remove?’ is closed to new replies.