• Archives are incomplete, missing files. XCloner displays messages indicating that the backup was successful, but it does not conform to reality.
    For example, the wp-content/plugins/ folder in the archive contains only part of one plugin.
    I tried to change settings but nothing improved the problem.
    Too bad because I found the new features interesting.

    The issue was solved after to modify the settings.

    • This topic was modified 3 years, 11 months ago by Jenny Dupuy. Reason: Issue solved
Viewing 8 replies - 1 through 8 (of 8 total)
  • @jdy68, did you create a support ticket? If you didn’t, can you create one. The plugin developer will kindly and promptly assist you with your issue.

    Kind regards

    • This reply was modified 3 years, 12 months ago by mbrsolution.

    Xcloner does have a logger where you can check the status of a file, if it maybe was excluded, then you should see the reason there. There is a setting in xcloner which excludes files using a regex pattern, default are .svn, .git and cache folders, as well as some other backup plugins folder, you can always change that as needed.

    It would help indeed to give us more details on the issue, which file(s) were missing and what was the logger output.

    Thread Starter Jenny Dupuy

    (@jdy68)

    Hi,

    I did three tests.

    In the first test:
    The Regex Exclude Files field, the value is by default =

    (wp-content\/updraft|wp-content\/uploads\/wp_all_backup)(.*)$
    (.*)\.(svn|git)(.*)$
    wp-content\/cache(.*)$

    and in the file options I’m excluding all directories except ‘wp-content’ and the files at the root.
    The backup has a size of 19MB.

    In the second test:
    The Regex Exclude Files field is empty
    and in the file options I’m excluding all directories except ‘wp-content’ and the files at the root.
    The backup has a size of 19MB, and for example the files in ‘uploads’ directory are not in the backup.

    The archives of test 1 et test 2 are identical except the folder containing the sql file of database.

    In the third test:
    The Regex Exclude Files field is empty
    and in the file options I’m excluding nothing.
    The backup has a size of 19MB and when I want to unzip it, I had a error message:
    ‘Headers error; Warning: There are some data after the end of payload data’.

    If that can help…

    Thread Starter Jenny Dupuy

    (@jdy68)

    After these three tests I made a fourth one where I modified the value of the field ‘Exclude files larger than (MB)’ in the Settings > System Options to empty (before it was ‘-1’), because in the backup log for some files I had ‘matching pattern > -1MB [“FILESYSTEM SCAN”,”EXCLUDE”]’.

    But when I unzip the archives, I had the same message ‘Headers error; Warning: There are some data after the end of payload data’ and the folders are empty (only names of folders).

    I understand less and less.

    Hi jdy, now that would explain the file exclusion, it could be that -1 was picked up from the previous XCloner install, so i will have that checked.

    Regarding Headers error, can you tell us if you are able to List the backup content ok(no errors), by using the “List Backup Content” button from the Manage Backups section, right to the backup name? If it works with no errors, then your issue is related to this bug https://github.com/ovidiul/XCloner-Wordpress/issues/2 which should be fixed, so please try to either reinstall XCloner or try the new version i am preparing 4.0.2 from here https://downloads.wordpress.org/plugin/xcloner-backup-and-restore.4.0.2.zip

    Thanks for taking your time to debug this and let me know if you continue to have issues.

    • This reply was modified 3 years, 11 months ago by Liuta Ovidiu.
    Thread Starter Jenny Dupuy

    (@jdy68)

    I’ve deleted and reinstalled the plugin, and that works !
    Why not make a new version when there are changes?
    We would be informed of changes at least

    Thanks for the help too.

    I will release the new version after i am done testing it, so hopefully next week it will be up.

    Glad to hear you got it all working!

    @jdy68, perhaps now that you have the plugin working you could change your rating from a 1 star to something higher.

    Kind regards

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Archives are incomplete’ is closed to new replies.