Support » Fixing WordPress » Archive/Permalink/Category Links Not Working

  • I upgraded to 2.5 a couple nights ago. This problem may have existed before then, but I think I would have noticed it.

    My web address:

    My problem is that when you click any of the months in the archive, or if you click what should be a permalink or if you click a category name it doesn’t actually do what you want it to. It changes the address in the address bar, but you have the same view you did previously (most recent entries). Using the search bar also takes you back to the same ‘main’ page.

    Is anyone else having this trouble since updating to 2.5? Is it a problem with the theme possibly? I generally keep the same theme, I just change the colors and the header. I did try changing it back to the default theme, and the problem still exists.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi there,

    This may be related to a thread at:

    which in honesty I did not really understand, however, I gleaned enough from it for my own – admittedly lame – fix at:

    Good luck – and if you do find out how to fix your issue properly, perhaps you’d be good enough to do a post for the rest of us, or even a link, please? Thanks.

    To the OP:
    that sounds like a permalinks issue. Did you try re-setting your permalinks?
    Using_Permalinks < for documentation

    i had the same problem but it stopped when i deleted the plugin “top level catagories” and the .htaccess file. wordpress made a new one it all worked again.

    in 2.5 there was no need for me to have top level catagories plugin as it allready has it built in.

    just thought that might help ya out.

    I am having exactly the same problem on only ONE of my many client sites all on the same host (Dreamhost)and have just spent 2 days trying to fix this to no avail. Weirdly, a few of the links in the menu do work for some reason, even though they are all written the same way :


    I first discovered this when wp_list_categories didn’t work properly; the URL looked like : but the page content was defaulting to the page.php (because I removed archive and category).

    I have Permalinks set to Day/Name (same as all my other sites)

    Site resides in subdirectory with General options like this :

    The original .htaccess setup was as follows :

    .htaccess file

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    index.php in :

    /* When WordPress files are in subdirectory of domain */
    define(‘WP_USE_THEMES’, true);

    In :

    .htaccess file :


    index.php :

    /* Short and sweet */
    define(‘WP_USE_THEMES’, true);

    I have never been able to confirm if there should or shouldn’t be multiple .htaccess files but after updating to 2.5.1, updating Permalinks created a new .htaccess inside the subdirectory even though there was one in the domain root.

    Help, help, help! I have tried the Jacquith plugin (disable canonical URL, and nothing. I have tried default Permalink structure and index.php?page_id=3 links and no go. I tried changing default (blank) Category base and nothing. I tried other Permalink structures and verified .htaccess. Nada. There are no extra tables in the DB. I have few plugins and they all seem to function here and on my other sites.


    Additional info :

    I just tried activating the default theme and Permalinks to all my pages work. As previously mentioned, several of my pages are working properly with Permalinks, so by messing around, I discovered that my page.php is apparently breaking Permalinks but I cannot figure out why.

    Any template I create using Improved Include Page to show the page content also works just fine, which is the case for all the links that are still functioning.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Archive/Permalink/Category Links Not Working’ is closed to new replies.