Support » Plugin: Multisite Language Switcher » archive slug incorrect

  • Resolved wouterdoorn

    (@wouterdoorn)


    Hi,

    first of all, thanks for the great plugin! It is doing an amazing job for our nonprofit website.

    Now to the question. I recently decided to make page for guest-authors using Shoofly Guest Auuthor Premium plugin. It creates an archive page for each author, for example https://buddho.org/about-the-author/ajahn-chah/

    The problem is that I can’t get MSLS to work (it does works for all other pages). In the footer and main menu of our website it keeps pointing to the wrong url for the Dutch/English language switchter (in the footer it actually doesn’t even offer the option to switch anymore) and the hreflang aren’t correct. I tried the permalinks hook from your website for the slug but it didn’t have any effect. Now I am not sure if it is a general problem with archive pages since I can’t link them up manually, or something specific with the Guest Author plugin (I don’t have any other archive pages). In the settings menu for MSLS it does show the correct slug for Guest Author in both the Dutch and English version, so MSLS does seem to recognize the Guest Author plugin and slug.

    Any ideas?

    Best,

    Wouter

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter wouterdoorn

    (@wouterdoorn)

    I got it to work! Apart from the right code for the query itself (which I got with the help of the Guest Author plugin author) al that was needed was a wp_reset_query() at the end of the query after which adding the permalink hook in functions.php to change de slug translation finally worked.

    Plugin Author Dennis Ploetner

    (@realloc)

    Very good. Thanks for pointing it out!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.