Support » Theme: evolve » archive.php not loading?

  • Resolved zulok

    (@zulok)


    Hello

    When I request the following URL http://localhost/VANILLA/2018 to get the archived posts I have found a strange behaviour

    • Instead of displaying posts from left to right, and then the next row it seems that it builds the archives page by columns (first column from top to down, next second column from top to down, and then the third)
    • When the blog layout is 2 or 3columns, the rightmost archived posts flicker until the full page is loaded. Actually it displays sequentially the posts on the top and then they are sorted vertically?
    • It does not seem to load archive.php from the template.

    Thank you very much

    Zulok

    • This topic was modified 5 years, 6 months ago by zulok.
    • This topic was modified 5 years, 6 months ago by zulok.
Viewing 10 replies - 1 through 10 (of 10 total)
  • can you please provide the URL to have a look? thanks

    Thread Starter zulok

    (@zulok)

    Hi Romik

    I usually work in a local stage and I am still making the child theme adjustements, but have cloned the site here

    You can try this

    http://test.mestresdevida.cat/2016/
    http://test.mestresdevida.cat/2017/
    http://test.mestresdevida.cat/2018/

    Forget about this issue “It does not seem to load archive.php from the template.” It was my fault debugging

    Child Thema and all plugins are disabled. Version 3.8.4 is still live @ mestresdevida.cat

    Thanks

    Zulok

    • This reply was modified 5 years, 6 months ago by zulok.

    Yes, the blog grid layout uses the Bootstrap Card system which shows items from top to bottom, then same for the next columns. I would also suggest you to set much less posts per page as your website takes too long to load. E.g. 10 items.

    Thread Starter zulok

    (@zulok)

    Hi Romik

    The example is in an archive pages; not something user access frequently so the load time is a little bit less relevant, and I will reduce the number of posts indeed.

    What about the flickering?

    Thanks

    Zulok

    Flickering because loading too many items 🙂 as mentioned, reduce the number of items

    Thread Starter zulok

    (@zulok)

    Hi Romik

    V3.8.4 did not flickr with that much items…

    Can be Bootstrap Card be skipped?

    Thanks

    Zulok

    if wanna have so many items, what about use the infinite scroll loading?

    Thread Starter zulok

    (@zulok)

    Hi Romik

    I do not know about the possibility of infinite scroll loading. I tried the one column layout but I do not like it much.

    The number of items is not a priority. I just would like to remove the flickr. In my humble opinion it does not only depend on the number of items but on the weight / size of the images. So, if I reduce the number of items I will not be sure of having removed the flickering…

    I am considering to modify the code not to use Bootstrap Card and get back the archive functionality of 3.8.4 through the Child Them… but I have not even analysed how hard this would be.

    Without being sure that flickr is removed I will not put this version live. This upgrade has taken a lot more of time for fixing and I do not still know what I still have to face to solve everything…

    Thanks

    Zulok

    could you maybe show a video screencast of the flickering if we mean the same thing 🙂

    Thread Starter zulok

    (@zulok)

    .

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘archive.php not loading?’ is closed to new replies.