Support » Plugin: Testimonials by WooThemes » archive page – base premalink

Viewing 3 replies - 1 through 3 (of 3 total)
  • bizspruiker

    (@bizspruiker)

    im having this problem too, its doing my head in! can anyone help?

    Amber

    (@syrehn)

    I just discovered this as well and it was driving me bonkers @_@

    I’m not a huge advocate of editing core code (as updates will break your modifications), however, the line ‘has_archive’ => ‘testimonials’, appears to be the issue:
    (found in testimonials-by-woothemes/classes/class-woothemes-testimonials.php)

    $args = array(
    			'labels' => $labels,
    			'public' => true,
    			'publicly_queryable' => true,
    			'show_ui' => true,
    			'show_in_menu' => true,
    			'query_var' => true,
    			'rewrite' => array( 'slug' => 'testimonial' ),
    			'capability_type' => 'post',
    			'has_archive' => 'testimonials',
    			'hierarchical' => false,
    			'supports' => array( 'title', 'editor', 'thumbnail', 'page-attributes' ),
    			'menu_position' => 5,
    			'menu_icon' => ''

    I temporarily commented out the line ‘has_archive’ => ‘testimonials’, by changing it to: /*’has_archive’ => ‘testimonials’,*/

    I then re-saved my permalink structure and viola I am now able to use the page ‘testimonials’.

    Ulrich

    (@grapplerulrich)

    This is solution will work with version 1.4.1

    Add this php code to the functions.php of your child theme

    /**
     * Changes testimonial archives URL slugs
     */
    function testimonials_archive_slug( $archive_slug ) {
    	$new_archive_slug = _x( 'testimonials-archive', 'post archive url slug', 'woothemes-testimonials' );
    	return $new_archive_slug;
    }
    add_filter( 'woothemes_testimonials_archive_slug', 'testimonials_archive_slug' );

    After adding you will need to resave the permalinks settings to save the new slug.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘archive page – base premalink’ is closed to new replies.