Support » Plugin: Dynamic Time » Approve button issue

  • subhamkotnala

    (@subhamkotnala)


    Hi,
    I have set the supervisor to admin. As an admin when I am viewing the submitted time report of an user, the approve button is not enabled. I had to submit again from the backend as an admin. Then the approve button is enabled. But that should not be the case right? How can I fix this?
    If you did not understand my issue, I can be more clear. Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Rhett

    (@rermis)

    Hi subhamkotnala, you are correct that the approve button should be enabled after a period is submitted. Can you ensure that:

    1) There is no caching enabled on the timecard page
    2) You are signed in as a supervisor or admin when approving (You may need to be incognito in one or the other).
    3) You are attempting to approve a time period that has been submitted

    Thank you in advance for verifying.

    Plugin Author Rhett

    (@rermis)

    Can you ensure that the pay period beginning and end dates match up on both the admin screen and user screen? Sometimes, especially when using bi-weekly periods, the periods may not match. If this is the case, you can click the dates at the top of the timecard to advance pay periods in one week increments, forward or reverse. As soon as the period matches what was originally submitted or approved, the buttons should line up.

    subhamkotnala

    (@subhamkotnala)

    Hi, I will be more clear. I am logged in as a Subscriber from Mozilla. The subscriber views a page where Dynamic Time shortcode is pasted. He is now filling the time report and submitting. Now the submitted time report has reached the admin dashboard in the backend. I am using Chrome for admin dashboard(Not incognito). Now when i click on view of the Subscriber’s time report. Then I can see that APPROVE is disabled but SUBMIT is enabled. I had to submit the subscriber’s time report again(which has been submitted already by the subscriber from the frontend), then the APPROVE button is enabled. But I think that should not be the case. As soon the subscriber clicks on SUBMIT from the frontend. The admin only has to approve it from the backend. I don’t understand why the approve button is not enabled as soon as the admins views the subscriber’s time report.
    I hope the issue is clear.
    Thank you for your patience.

    Plugin Author Rhett

    (@rermis)

    Hi subhamkotnala, yes I understand the issue. Without seeing it firsthand I must assume it is one of two things:

    1) The time period is not the same between the two screens. Can you verify the time period begin and end dates are the same on both the admin view and user view? If the dates do not match, click on the dates at the top of the timecard to navigate forward or back in one week increments.

    2) There must be a page reload/refresh on the admin side after a timecard is submitted. You can ensure this by reclicking the Dynamic Time WP menu item to reload the page.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.