Support » Plugins and Hacks » [Resolved] Approval Submission Error

[Resolved] Approval Submission Error

  • Hi!

    Great plugin, almost worked for us but we are seeing a hang up when the test client we have tries to approve a design. We are getting a console error here:

    Uncaught SyntaxError: Unexpected token <

    This happens when we press the OK button for the digital signature, then is just says “saving…”. The metadata does update and the designs gets set to approved, but not thank you message comes up and no emails get sent out.

    We have Easy WP SMTP setup for our mail and its sending out email correctly, not sure why we aren’t getting any emails from DAS.


Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author slickremix


    Sorry for the delay. It sounds like another plugin may be causing the error. Have you tried disabling all other plugin but the DAS and see if the problem persists?

    Thanks for getting back to me. We have a site set up for the specific purpose of using your plugin, so the only active plugins at the moment are the DAS plugin and the Custom Post Templates plugin. We have the default Twenty Fourteen theme.

    We do have the site installed on a Microsoft IIS 7 server, if that makes any difference. It seems like an AJAX or mail issue.

    I can give you temporary login information if that helps.

    That last console message to fire before the error is this:

    console.log(‘Form process sending’);

    Plugin Author slickremix


    Yes it’s sounding like it, although I can’t confirm without an example link. It may be worth checking to see if the sendmail feature is available on your server. It’s usually in the php.ini file that would be on the root of your server. Not really sure if your server type is the issue, although it could be. We have never tested on that environment before.
    Another option would be to use the SMTP and see if that works for ya, that’s one of the reason we developed that part, because some server don’t have sendmail setup or companies don’t want to allow that option and you need to request it be turned on… if possible.


    We can’t use sendmail because of the type of servers we use. We do however have the SMTP settings already set and active and we are still getting this error. I tested a separate SMTP config plugin and did a test email with that to confirm that the site does indeed send email correctly, so it must be something within the DAS SMTP logic?

    I don’t mind poking around in there, I just wanted to confirm whether or not you guys have seen this happen before. We really just need this test to work, the extensions to this plugin make it totally usable for our case scenario and it doesn’t seem like any other plugins come close.

    Also if you want to see what I mean I can send you login information to use on this test link:


    Plugin Author slickremix


    I mean really instead of struggling so much with your current server. Since realistically this is all based on a php environment why don’t you just get a cheap setup at godaddy or shoot I can hook you up with a good service for a good deal each year, and I know that the das system works with no issues on my servers too.

    Plugin Author slickremix


    but if you can poke around in there and find a solution for your environment we would definitely like to know so we can share with others, or possibly make it an option in the settings for a future update.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Approval Submission Error’ is closed to new replies.