Approval for comments not working (7 posts)

  1. kappaluppa
    Posted 10 years ago #

    All of a sudden (isn't that how it goes...) the requirement to approve all comments is not working. In Options --> Discussion I have the following checked:

    * Attempt to notify any Weblogs linked to from the article (slows down posting.)
    * Allow link notifications from other Weblogs (pingbacks and trackbacks.)
    * Allow people to post comments on the article

    E-mail me whenever:

    * Anyone posts a comment
    * A comment is held for moderation

    Before a comment appears:

    * An administrator must approve the comment (regardless of any matches below)
    * Comment author must fill out name and e-mail
    * Comment author must have a previously approved comment

    And, I've added simple words to the comment moderation section in hopes it would block auto posting of the comments.

    But the comments still automatically go up.

    Any ideas out there?


  2. Chris_K
    Posted 10 years ago #

    Spam comments?

    Install or activate either Spam Karma 2 or Akismet.

    Then go get Bad Behavior and activate it too.


  3. kappaluppa
    Posted 10 years ago #

    No, this does not have to do with spam.
    I want ALL comments held for moderation and have that box checked, but comments are still coming through without authorization.

  4. vectorboy
    Posted 10 years ago #

    Maybe you can try to update the .htaccess ...
    Good luck!

  5. Chris_K
    Posted 10 years ago #

    Alas, .htaccess changes won't help ensure that comments are held for moderation.

    Just for grins, what happens if you uncheck
    * Comment author must have a previously approved comment

  6. kappaluppa
    Posted 10 years ago #

    I tried both already - updating .htaccess AND using the 'reverse psychology' on the check boxes. and no go. I'm checking my db in phpMyAdmin, maybe the changes are not getting there.
    K <------------ puzzled and crossing fingers

  7. katford728
    Posted 9 years ago #

    I'm also having this problem. This worked fine before our blog went up today, but when it went live, this feature was not functioning. Can anyone help? Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.