Support » Plugin: Appointments » Appointment for One Service Creates Appointment for Two

  • Resolved ssgupta


    The free version let’s setting-up of two services max. If someone makes an appointment for one service, the other service too gets booked for the same date and time.

    There is the drop-down for the two services and, when selecting one or the other, the service ID is visible in the browser address bar as 1 or 2.

    Not sure if it is a bug or something I did not do.


Viewing 3 replies - 1 through 3 (of 3 total)
  • David


    WPMU DEV Support Staff

    Hi @ssgupta,

    Greetings and thanks for posting!

    I can’t seem to replicate that in a test site, though I’m sure we can sort this.

    When you say that both services get booked, do you mean that 2 appointments are created each time you schedule for either service?

    Appointments will all be displayed at:

    Are you seeing multiple appointments there when you schedule?


    My settings:

    One Service Provider
    Two Services

    My Appointments shows one booking
    All Appointments shows one booking

    But, the time slot in the two Calendars for the two services gets blocked simultaneously. Same date, same time slot.

    When I changed the settings to two service providers, one for each service, it did not happen. Only one time slot in one Calendar was blocked, as it should be.




    WPMU DEV Support Staff

    Hi @ssgupta,

    Thanks for clarifying that! Actually, that is how the plugin is designed to work. It automatically blocks out times on a Service Provider basis.

    If you need to allow multiple, simultaneous scheduling though, you can create Dummy providers and link that with your main Service Provider.

    You’ll see a bit more about the Dummy providers in the following from our video tutorial series:

    Does that make sense though?

    If anything’s unclear, just let me know. I’ll be happy to help. 🙂


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Appointment for One Service Creates Appointment for Two’ is closed to new replies.