Support » Plugin: WooCommerce Stripe Payment Gateway » Apply pay button not showing

  • Resolved Dimoteca

    (@albertsauque)


    Hello, I have setup stripe, but I cannot manage to see the button. I have gone through all the checks in the docs. Even the logs say:

    2022-07-05T08:19:35+00:00 DEBUG 
    ====Stripe Version: 6.4.3====
    ====Start Log====
    Your domain has been verified with Apple Pay!
    ====End Log====

    The files are there, everything should be ok.

    However no trace of the apple pay button using safari and iphone 12. Other sites showing button.
    I am using elementor to create the product page template. The google pay button is shown in chrome and android devices.

    How can I further debug this?

    Thanks

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Stuart Duff – a11n

    (@stuartduff)

    Automattic Happiness Engineer

    Hi @albertsauque

    To see the ApplePay buttons you would need to be browsing the website using the Safari Web browsers on either an iOS or MacOS device that has a valid ApplePay account and payment card added to it.

    You’d also need to have the Express Checkout buttons enabled within the Stripe plugin settings.


    Image Link: https://snipboard.io/31WYJv.jpg

    Regrettably, you’ve added a fake domain name to your forum topic so I couldn’t check your product, cart and checkout page for any ApplePay buttons.

    Thread Starter Dimoteca

    (@albertsauque)

    Hello, the domain that I have the issues with is:

    https://www.alessandrosimoni.com

    I have verified that all the checkboxes are marked. I’ve been checking with safari on a iPhone 12, so that is iOS.

    Thanks

    Plugin Support Stuart Duff – a11n

    (@stuartduff)

    Automattic Happiness Engineer

    Hey @albertsauque

    Thanks for referencing the site domain for us. Looking at the products on your site I can see the ApplePay button displayed like in this example below on the desktop.

    **Desktop**


    Image Link: https://snipboard.io/fhJKgU.jpg

    I don’t however see the ApplePay button displaying on my iPhone though.

    I also noticed when testing that GooglePay is displayed on a desktop version of Google Chrome but not on a Smartphone too.

    As it’s the exact same Expres payment buttons that are displayed on desktops and smartphones this indicates that potentially something isolated to your particular website site is preventing the buttons from displaying on smartphone devices.

    I tested on one of my installations and could not replicate the same behaviour and both the Google pay and ApplePay buttons were displayed on smartphone devices.

    From what we’re seeing, it could be code from another plugin or theme which has caused a possible conflict and affected the functionality of WooCommerce.

    To see if that is the case we’d suggest carrying out a conflict test on your site by disabling all other plugins aside from WooCommerce along with switching to a theme like Twenty Twenty Two. This will help with trying to and locate what software you have installed which could possibly be causing this behaviour? You could use a free plugin called Health Check and Troubleshooting to carry out such testing.

    When in Troubleshooting mode all plugins will be deactivated and only the admin of the site carrying out the troubleshooting would see those changes. Any customers visiting the site would see no changes at all.

    Once you have disabled all other plugins and switched themes if the behaviour is resolved you can then enable your theme and site plugins testing after each one is enabled until the behaviour returns to locate the culprit.

    https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    Thread Starter Dimoteca

    (@albertsauque)

    Hello,

    I can see in a few android devices the google pay button. So it makes me think it is directly related to apple pay.

    You can see it in this screenshot:
    https://snipboard.io/8mqTgi.jpg

    Any suggestions?

    Thanks

    Hi @albertsauque

    I’ve been checking with safari on a iPhone 12, so that is iOS.

    Can you please visit this link (https://stripe-payments-demo.appspot.com/) from your iPhone and confirm if you see the Apple Pay button?

    Thread Starter Dimoteca

    (@albertsauque)

    Hello,

    Yes I do see the APPLE PAY button.

    I had already checked that when troubleshooting.

    Thanks

    Plugin Support Joseph B. (a11n)

    (@tamirat22)

    Hello @albertsauque!

    Thanks for getting back to us!

    Yes I do see the APPLE PAY button.

    If the issue is present for Apple Pay only, please access the Apple Pay configuration on your Stripe Dashboard and make sure your domain is added to the Stripe dashboard exactly as it is resolved in the browser, without the www.

    Also, please share with us your Stripe logs from WooCommerce > Status > Logs.

    Thread Starter Dimoteca

    (@albertsauque)

    Hello,

    I just added the domain without the www. I had only added it with WWW.

    In the logs I see sensitive google pay data which I can’t share. However I can add a few lines:

    2022-07-05T08:19:35+00:00 DEBUG 
    ====Stripe Version: 6.4.3====
    ====Start Log====
    Your domain has been verified with Apple Pay!
    ====End Log====
    
    2022-07-05T09:57:02+00:00 DEBUG 
    ====Stripe Version: 6.4.3====
    ====Start Log====
    account
    ====End Log====

    I still don’t see the button, but maybe after adding without www, I need to wait? Or is it immediate?

    Also I have nothing in IOS certificates. Am I supposed to add a new application?

    Thanks

    Plugin Support Joseph B. (a11n)

    (@tamirat22)

    Hello @albertsauque!

    Thanks for the reply!

    I still don’t see the button

    In that case, your best bet is to run the conflict test or health check recommended earlier by @stuartduff and see if there are any changes.

    You can also look for and share with us any errors found under your browser console to see if any plugins or extensions are conflicting with your output.

    We will be here!

    Thread Starter Dimoteca

    (@albertsauque)

    I have a staging site, is it possible to run these type of tests under staging? or these environments aren’t allowed by apple pay?

    Thanks

    Plugin Support Brad P. a11n

    (@snaacks)

    Hi @albertsauque

    You should be able to test on your staging site so long as it matches your live site, but please let us know if you run into any trouble.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Apply pay button not showing’ is closed to new replies.